summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmytro Meleshko2020-08-27 10:25:01 +0300
committerDmytro Meleshko2020-08-27 10:29:27 +0300
commit551a2e6f354a3aedb34d98a33ec8bd1639bdc3a2 (patch)
tree25b48f4c2a2a311a9ed92dfa1919dfd5b6158bef
downloadaur-551a2e6f354a3aedb34d98a33ec8bd1639bdc3a2.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD31
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..074ce68ea643
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = haskell-wstunnel-bin
+ pkgdesc = Tunneling over websocket protocol
+ pkgver = 3.0
+ pkgrel = 1
+ url = https://github.com/erebe/wstunnel
+ arch = x86_64
+ license = BSD
+ provides = haskell-wstunnel
+ conflicts = haskell-wstunnel
+ conflicts = nodejs-wstunnel
+ source = haskell-wstunnel-bin-3.0.zip::https://github.com/erebe/wstunnel/releases/download/v3.0/wstunnel-x64-linux.zip
+ source = haskell-wstunnel-bin-3.0-LICENSE::https://github.com/erebe/wstunnel/raw/v3.0/LICENSE
+ source = haskell-wstunnel-bin-3.0-README.md::https://github.com/erebe/wstunnel/raw/v3.0/README.md
+ source = haskell-wstunnel-bin-3.0-logo.png::https://github.com/erebe/wstunnel/raw/v3.0/logo_wstunnel.png
+ sha256sums = 040b3d6d98b8d3ff0df2ba05b6b89e8a6820be981ffe4a3b39af563225f66098
+ sha256sums = eaea4f8a2ebca92e3ca13f77d01364b110723c70ed6370ce1ecdb4f84261d411
+ sha256sums = c408ac4b73b05052357f6a598b961f9fb73ddc29df296febdf06842ceaaa6422
+ sha256sums = e193de98502986dfb54639058b1409e92282f78b54d04b0d2735d4b4c9be2b77
+
+pkgname = haskell-wstunnel-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0b1562ff8011
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/pkg/
+/src/
+/haskell-wstunnel-bin-*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47c482dcc350
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Dmytro Meleshko <dmytro.meleshko@gmail.com>
+_projname=wstunnel
+_pkgname=haskell-"${_projname}"
+pkgname="${_pkgname}"-bin
+pkgver=3.0
+pkgrel=1
+pkgdesc="Tunneling over websocket protocol"
+arch=('x86_64')
+url="https://github.com/erebe/wstunnel"
+license=('BSD')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}" 'nodejs-wstunnel')
+source=("${pkgname}-${pkgver}.zip::https://github.com/erebe/${_projname}/releases/download/v${pkgver}/${_projname}-x64-linux.zip"
+ "${pkgname}-${pkgver}-LICENSE::https://github.com/erebe/${_projname}/raw/v${pkgver}/LICENSE"
+ "${pkgname}-${pkgver}-README.md::https://github.com/erebe/${_projname}/raw/v${pkgver}/README.md"
+ "${pkgname}-${pkgver}-logo.png::https://github.com/erebe/${_projname}/raw/v${pkgver}/logo_${_projname}.png")
+sha256sums=('040b3d6d98b8d3ff0df2ba05b6b89e8a6820be981ffe4a3b39af563225f66098'
+ 'eaea4f8a2ebca92e3ca13f77d01364b110723c70ed6370ce1ecdb4f84261d411'
+ 'c408ac4b73b05052357f6a598b961f9fb73ddc29df296febdf06842ceaaa6422'
+ 'e193de98502986dfb54639058b1409e92282f78b54d04b0d2735d4b4c9be2b77')
+
+prepare() {
+ sed -i "s|https://github.com/erebe/${_projname}/raw/master/logo_${_projname}.png|logo.png|g" "${pkgname}-${pkgver}-README.md"
+}
+
+package() {
+ install -Dm755 "${_projname}" "${pkgdir}/usr/bin/${_projname}"
+ install -Dm644 "${pkgname}-${pkgver}-LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "${pkgname}-${pkgver}-README.md" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
+ install -Dm644 "${pkgname}-${pkgver}-logo.png" "${pkgdir}/usr/share/doc/${_pkgname}/logo.png"
+}