summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeif Warner2018-01-27 01:29:14 -0800
committerLeif Warner2018-01-27 01:29:14 -0800
commit9aabbed54cfa907ddc651a14fe464ab29f87e69b (patch)
tree8ecb801d8f7aed9d525ec6ca167f83dc12bf2042
downloadaur-9aabbed54cfa907ddc651a14fe464ab29f87e69b.tar.gz
Initial commit -v0.2.2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD41
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9482c908e6d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat Jan 27 09:28:25 UTC 2018
+pkgbase = haskell-xdg-basedir
+ pkgdesc = A basic implementation of the XDG Base Directory specification.
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = http://github.com/willdonnelly/xdg-basedir
+ arch = i686
+ arch = x86_64
+ license = BSD3
+ depends = ghc
+ source = http://hackage.haskell.org/packages/archive/xdg-basedir/0.2.2/xdg-basedir-0.2.2.tar.gz
+ sha256sums = e461c3a5c6007c55ceaea03be3be0ef3a92aa0ea1aea936da0c43671bbfaf42b
+
+pkgname = haskell-xdg-basedir
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2647f0efc32f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# custom variables
+_hkgname=xdg-basedir
+
+# PKGBUILD options/directives
+pkgname=haskell-xdg-basedir
+pkgver=0.2.2
+pkgrel=1
+license=('BSD3')
+pkgdesc="A basic implementation of the XDG Base Directory specification."
+url="http://github.com/willdonnelly/xdg-basedir"
+arch=('i686' 'x86_64')
+depends=("ghc")
+source=("http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+
+sha256sums=("e461c3a5c6007c55ceaea03be3be0ef3a92aa0ea1aea936da0c43671bbfaf42b")
+
+# PKGBUILD functions
+
+build() {
+ cd "${srcdir}/${_hkgname}-${pkgver}"
+
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
+ --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd "${srcdir}/${_hkgname}-${pkgver}"
+
+ install -D -m744 register.sh "${pkgdir}/usr/share/haskell/${pkgname}/register.sh"
+ install -m744 unregister.sh "${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh"
+
+ runhaskell Setup copy --destdir="${pkgdir}"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+}