summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDestructiveReasoning2016-03-01 19:20:42 +0000
committerDestructiveReasoning2016-03-01 19:20:42 +0000
commit8ca110b2de7a05d00bf50c183557be7968b77119 (patch)
tree1e2a3fbd9029c74ce0e2f5abaac229f875678306
downloadaur-8ca110b2de7a05d00bf50c183557be7968b77119.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rwxr-xr-xPKGBUILD59
-rw-r--r--hasklock.install11
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a5e36d350ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Mar 1 19:20:23 UTC 2016
+pkgbase = hasklock
+ pkgdesc = A binary clock in ncurses written in Haskell
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/DestructiveReasoning/hasklock
+ install = hasklock.install
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = ncurses
+ source = hasklock::git+https://github.com/DestructiveReasoning/Conway.git
+ md5sums = SKIP
+
+pkgname = hasklock
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..6daeb0c26ecb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Harley Wiltzer <harleyw@hotmail.com>
+pkgname=hasklock
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="A binary clock in ncurses written in Haskell"
+arch=('x86_64')
+url="https://github.com/DestructiveReasoning/hasklock"
+license=('BSD')
+groups=()
+depends=('ncurses')
+makedepends=('git')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=hasklock.install
+source=($pkgname::git+https://github.com/DestructiveReasoning/Conway.git)
+noextract=()
+md5sums=('SKIP') #generate with 'makepkg -g'
+
+_gitroot=https://github.com/DestructiveReasoning/hasklock.git
+_gitname=hasklock
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+ #
+ # BUILD HERE
+ #
+#./autogen.sh
+# ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ make
+ install -Dm 755 Hasklock "$pkgdir/usr/bin/$_gitname"
+#make DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=2 sw=2 et:
+md5sums=('SKIP')
diff --git a/hasklock.install b/hasklock.install
new file mode 100644
index 000000000000..2eaa60550d51
--- /dev/null
+++ b/hasklock.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}