summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzneix2021-05-10 19:11:01 +0200
committerzneix2021-05-10 19:11:01 +0200
commitdfba31594b9766a99932a58863ea8a204a87ca5b (patch)
tree9a19c3f47f479e9c10cba66f90771058133885ad
downloadaur-dfba31594b9766a99932a58863ea8a204a87ca5b.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore11
-rw-r--r--Makefile15
-rw-r--r--PKGBUILD32
-rw-r--r--haste-client-git.changelog3
5 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c708d7712b2d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = haste-client-git
+ pkgdesc = A little utility for uploading code to hastebin server, written in Go.
+ pkgver = r11.00dea98
+ pkgrel = 1
+ url = https://github.com/zneix/haste-client
+ changelog = haste-client-git.changelog
+ arch = x86_64
+ license = AGPL3
+ makedepends = go
+ makedepends = git
+ makedepends = make
+ provides = haste
+ conflicts = haste-client
+ conflicts = haste-client-bin
+ source = haste-client::git://github.com/zneix/haste-client.git
+ sha256sums = SKIP
+
+pkgname = haste-client-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8855812a5681
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,11 @@
+*.tar.xz
+*.tar.gz
+*.tar.zst
+
+pkg
+src
+
+haste-client-git*
+!haste-client-git.changelog
+haste-client
+haste
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..9163e0ca2609
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,15 @@
+.PHONY: all
+
+all: clean rebuild changelog srcinfo
+
+rebuild:
+ makepkg -s
+
+changelog:
+ curl -L https://raw.githubusercontent.com/zneix/haste-client/master/CHANGELOG.md > haste-client-git.changelog
+
+srcinfo:
+ makepkg --printsrcinfo > .SRCINFO
+
+clean:
+ rm -rf pkg src haste-client*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c087a6571f3b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: zneix <zneix@zneix.eu>
+
+pkgname=haste-client-git
+pkgver=r11.00dea98
+pkgrel=1
+pkgdesc="A little utility for uploading code to hastebin server, written in Go."
+arch=('x86_64')
+url="https://github.com/zneix/haste-client"
+license=('AGPL3')
+depends=()
+makedepends=('go' 'git' 'make')
+provides=('haste')
+conflicts=('haste-client' 'haste-client-bin')
+options=()
+changelog=$pkgname.changelog
+source=('haste-client::git://github.com/zneix/haste-client.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/haste-client"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/haste-client"
+ go build -o haste
+}
+
+package() {
+ cd "$srcdir/haste-client"
+ install -Dm 755 haste "$pkgdir/usr/bin/haste"
+}
diff --git a/haste-client-git.changelog b/haste-client-git.changelog
new file mode 100644
index 000000000000..f8ba3d74b863
--- /dev/null
+++ b/haste-client-git.changelog
@@ -0,0 +1,3 @@
+# Unversioned
+
+