summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-11 17:35:02 +0800
committerzxp198210052024-03-11 17:35:02 +0800
commit625a9726f1cdd0f053c283b3e73d406851d7a180 (patch)
tree5e2296693ae0fd5a82c990da49e2bfbfe5a92a25
parent14ef60008f6e0edf2d98ef286effc56fea4e5eb3 (diff)
downloadaur-625a9726f1cdd0f053c283b3e73d406851d7a180.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--hathor-wallet.sh8
3 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf0472bbdbdc..4221c48ba00c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hathor-wallet-bin
pkgdesc = Hathor Official Wallet for Desktop
pkgver = 0.27.1
- pkgrel = 1
+ pkgrel = 2
url = https://hathor.network/
arch = x86_64
license = MIT
@@ -14,6 +14,6 @@ pkgbase = hathor-wallet-bin
source = hathor-wallet.sh
sha256sums = e632985f74322612ca0cddf8b6f58324577e6e2bef7cb2763928410986901013
sha256sums = 8fc34ede2d7615b4ef2eee1acfa4a457ab3e7c317e4ba6a1354b3b57ad11cbd0
- sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = hathor-wallet-bin
diff --git a/PKGBUILD b/PKGBUILD
index 2acafa2caca0..c4d4a145858f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=hathor-wallet-bin
_pkgname="Hathor Wallet"
pkgver=0.27.1
_electronversion=27
-pkgrel=1
+pkgrel=2
pkgdesc="Hathor Official Wallet for Desktop"
arch=('x86_64')
url="https://hathor.network/"
@@ -22,11 +22,12 @@ source=(
)
sha256sums=('e632985f74322612ca0cddf8b6f58324577e6e2bef7cb2763928410986901013'
'8fc34ede2d7615b4ef2eee1acfa4a457ab3e7c317e4ba6a1354b3b57ad11cbd0'
- '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data."*
sed "s|\"/opt/${_pkgname}/${pkgname%-bin}\"|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
diff --git a/hathor-wallet.sh b/hathor-wallet.sh
index f9ced1432cfc..7ddcaab8d734 100644
--- a/hathor-wallet.sh
+++ b/hathor-wallet.sh
@@ -1,14 +1,16 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file