summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomasTraineau2023-03-25 11:33:36 +0100
committerThomasTraineau2023-03-25 11:33:36 +0100
commit261f463f892c47b93b96fee291610826fb1a293d (patch)
treee5ddfcc7d3e10071518a98126721711297907fdd
downloadaur-261f463f892c47b93b96fee291610826fb1a293d.tar.gz
first commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c278a9d0426
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = hatt-bin
+ pkgdesc = Tool to search for files through multiple websites
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/FrenchGithubUser/Hatt
+ arch = x86_64
+ license = GPL
+ provides = hatt
+ conflicts = hatt
+ source = https://raw.githubusercontent.com/FrenchGithubUser/Hatt/main/frontend/public/images/hatt-logo.png
+ source = https://raw.githubusercontent.com/FrenchGithubUser/Hatt/main/.pkg/hatt-bin.desktop
+ sha256sums = SKIP
+ sha256sums = SKIP
+ source_x86_64 = https://github.com/FrenchGithubUser/Hatt/releases/download/0.1/hatt-linux-x86_64
+ sha256sums_x86_64 = SKIP
+
+pkgname = hatt-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37b6a560caee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: FrenchGithubUser < nomail >
+pkgname='hatt-bin'
+_pkgname="hatt"
+pkgver=0.1
+pkgrel=1
+pkgdesc="Tool to search for files through multiple websites "
+arch=('x86_64')
+url="https://github.com/FrenchGithubUser/Hatt"
+_assets_url="https://raw.githubusercontent.com/FrenchGithubUser/Hatt/main"
+license=('GPL')
+#depends=("")
+#makedepends=("")
+#optdepends=("")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_assets_url/frontend/public/images/hatt-logo.png" "$_assets_url/.pkg/hatt-bin.desktop")
+source_x86_64=("${url}/releases/download/${pkgver}/hatt-linux-x86_64")
+sha256sums_x86_64=('SKIP')
+sha256sums=('SKIP' 'SKIP')
+
+
+package() {
+ install -Dm755 "$_pkgname-linux-$CARCH" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$_pkgname.desktop
+ install -Dm644 $srcdir/$_pkgname-logo.png $pkgdir/usr/share/pixmaps/$_pkgname.png
+}