summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Pelz2017-05-10 14:26:11 +0200
committerFlorian Pelz2017-05-10 14:26:11 +0200
commit878dd712c0b22dc31dbd632c195555d3115ea97c (patch)
tree83dd0d1a70d769d879634a19e3d05f5efc0e0f7f
downloadaur-878dd712c0b22dc31dbd632c195555d3115ea97c.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..afc9b527f589
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = haunt
+ pkgdesc = Static site generator written in Guile Scheme
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://haunt.dthompson.us
+ arch = any
+ license = GPL3
+ makedepends = guile-reader
+ makedepends = guile-commonmark
+ depends = guile
+ optdepends = guile-reader: Skribe support
+ optdepends = guile-commonmark: CommonMark support
+ source = https://files.dthompson.us/haunt/haunt-0.2.1.tar.gz
+ sha512sums = 4520e3f8793588559eafe6dd0d6b4bea2e892b3a9c2bdcd740e164bd453690cc98f97ae3d30ce385203739ca6735ea6c321f05a3e1336035a00f780b06859ff2
+
+pkgname = haunt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4888c1a9dc5d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Florian Pelz <pelzflorian at pelzflorian.de>
+pkgname=haunt
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="Static site generator written in Guile Scheme"
+arch=('any')
+url="https://haunt.dthompson.us"
+license=('GPL3')
+depends=('guile')
+optdepends=('guile-reader: Skribe support'
+ 'guile-commonmark: CommonMark support')
+makedepends=('guile-reader' 'guile-commonmark')
+source=("https://files.dthompson.us/haunt/${pkgname}-${pkgver}.tar.gz")
+sha512sums=('4520e3f8793588559eafe6dd0d6b4bea2e892b3a9c2bdcd740e164bd453690cc98f97ae3d30ce385203739ca6735ea6c321f05a3e1336035a00f780b06859ff2')
+
+build() {
+ cd "$pkgname"-"$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$pkgname"-"$pkgver"
+ make check
+}
+
+package() {
+ cd "$srcdir"/"$pkgname"-"$pkgver"
+ make DESTDIR="$pkgdir/" install
+}