summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorabs3nt2023-03-08 12:44:58 -0800
committerabs3nt2023-03-08 12:57:08 -0800
commit99531a6a90dc5495fe24bf670304443309115b3b (patch)
tree7a6a45af3fd5bf969b73ef4a0dbedb68bafcb573
downloadaur-99531a6a90dc5495fe24bf670304443309115b3b.tar.gz
initial
initial
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD39
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ce823eaa9de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = haunt-git
+ pkgdesc = Live reload and task automation for go apps
+ pkgver = 0.2.6.r1.g4020301
+ pkgrel = 1
+ url = https://gitea.asdf.cafe/abs3nt/haunt
+ arch = x86_64
+ license = GPL
+ makedepends = go
+ provides = haunt
+ conflicts = haunt
+ source = git+https://gitea.asdf.cafe/abs3nt/haunt.git
+ sha256sums = SKIP
+
+pkgname = haunt-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7e2679b2c099
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+#Ignore everything
+*
+
+#But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce4d3744cc09
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+pkgname=haunt-git
+_pkgname=haunt
+pkgver=0.2.6.r1.g4020301
+pkgrel=1
+pkgdesc='Live reload and task automation for go apps'
+arch=('x86_64')
+url="https://gitea.asdf.cafe/abs3nt/$_pkgname"
+license=('GPL')
+provides=($_pkgname)
+conflicts=($_pkgname)
+makedepends=('go')
+source=("git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $_pkgname
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build .
+ ./$_pkgname completion zsh > $(_pkgname)_zsh
+ ./$_pkgname completion bash > $(_pkgname)_bash
+ ./$_pkgname completion fish > $(_pkgname)_fish
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm755 $_pkgname "$pkgdir"/usr/bin/$_pkgname
+ install -Dm644 $(_pkgname)_zsh "$pkgdir"/usr/share/zsh/site-functions/_$_pkgname
+ install -Dm644 $(_pkgname)_bash "$pkgdir"/usr/share/bash-completion/completions/$_pkgname
+ install -Dm644 $(_pkgname)_fish "$pkgdir"/usr/share/fish/vendor_completions.d/$_pkgname.fish
+}