aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYash Karandikar2020-03-17 09:44:02 -0500
committerYash Karandikar2020-03-17 09:44:02 -0500
commit0ad5bd20cf1a3d9e9d8b06799a4eb0ba7454909f (patch)
tree0d3d86e79bf0654aea1fcaae86c7fbdb37017dc1
parentff3acd9d6ff0a3db23390a19d43e95fbeab2e04c (diff)
parent22576ad572dec48f28ad3d05cf4542c016ea4624 (diff)
downloadaur-0ad5bd20cf1a3d9e9d8b06799a4eb0ba7454909f.tar.gz
Change default configuration file location
-rw-r--r--.SRCINFO4
-rw-r--r--Makefile2
-rw-r--r--PKGBUILD4
-rwxr-xr-xhaur4
4 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e11a7272dbe..3b7eff59d669 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,9 +12,9 @@ pkgbase = haur
source = haur
source = haurrc
source = Makefile
- md5sums = 22c5c88ce11a0a12716ce8ae98bf2553
+ md5sums = 1f5aeca9de0c6e25b5894c60ca8e733b
md5sums = 2c9bb36e3d797a6a3462bf69b6033cfe
- md5sums = c1051c8c4fe078e1f90b1ff0278f6a8d
+ md5sums = 4559d231974618def3ab832ad21f9e0d
pkgname = haur
diff --git a/Makefile b/Makefile
index da0562b506a0..93b5d41a564d 100644
--- a/Makefile
+++ b/Makefile
@@ -3,6 +3,6 @@ clean:
rm -rf pkg/ src/
install:
install -Dm777 ${srcdir}/haur ${pkgdir}/usr/bin/haur
- install -Dm644 ${srcdir}/haurrc ${pkgdir}/etc/haurrc
+ install -Dm644 ${srcdir}/haurrc ${pkgdir}/usr/share/haur/haurrc
test:
bash test.sh
diff --git a/PKGBUILD b/PKGBUILD
index 234ca6d7480e..58dd69fde371 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,6 +16,6 @@ prepare () {
package () {
make install srcdir=$srcdir pkgdir=$pkgdir
}
-md5sums=('22c5c88ce11a0a12716ce8ae98bf2553'
+md5sums=('1f5aeca9de0c6e25b5894c60ca8e733b'
'2c9bb36e3d797a6a3462bf69b6033cfe'
- 'c1051c8c4fe078e1f90b1ff0278f6a8d')
+ '4559d231974618def3ab832ad21f9e0d')
diff --git a/haur b/haur
index 8d2d6305b487..35d4c2419f5f 100755
--- a/haur
+++ b/haur
@@ -9,9 +9,9 @@ if [ -f "$HOME"/.config/haurrc ]; then
# shellcheck source=/dev/null
source "$HOME"/.config/haurrc
else
- if [ -f /etc/haurrc ]; then
+ if [ -f /usr/share/haur/haurrc ]; then
# shellcheck source=/dev/null
- source /etc/haurrc
+ source /usr/share/haur/haurrc
else
die "fatal: No configuration file found"
fi