summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiganic2015-06-09 00:09:34 +0200
committerLiganic2015-06-09 00:09:34 +0200
commit5c496169f70fde892608b0c160d940d2719b68a1 (patch)
treeb523998bad63d665c378f57bbdd8ce78069deb4e
downloadaur-5c496169f70fde892608b0c160d940d2719b68a1.tar.gz
Initial commit of Hawkthorne Journey to AUR4
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
-rw-r--r--hawkthorne.desktop10
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..49822aac6ae3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = hawkthorne-journey-git
+ pkgdesc = This 2d platformer is based on Community's Digital Estate Planning episode. It's built using the love game engine.
+ pkgver = v0.0.76_2492_g04ee9e8
+ pkgrel = 1
+ url = https://github.com/kyleconroy/hawkthorne-journey
+ arch = i686
+ arch = x86_64
+ license = MIT+CCPL
+ makedepends = git
+ makedepends = zip
+ makedepends = unzip
+ depends = love
+ source = hawkthorne.desktop
+ source = hawkthorne-journey-git::git+https://github.com/hawkthorne/hawkthorne-journey.git
+ sha256sums = bb4d44614e868585b9079cdf1de5039c73bbfe433faf13c9fc7d3c27c254527e
+ sha256sums = SKIP
+
+pkgname = hawkthorne-journey-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf219fe09660
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Liganic <liganic-aur@gmx.net>
+# Contributor: ajs124 <ajs@online.de>
+
+pkgname=hawkthorne-journey-git
+pkgver=v0.0.76_2492_g04ee9e8
+pkgrel=1
+pkgdesc="This 2d platformer is based on Community's Digital Estate Planning episode. It's built using the love game engine."
+arch=('i686' 'x86_64')
+url="https://github.com/kyleconroy/hawkthorne-journey"
+license=('MIT+CCPL')
+depends=('love')
+makedepends=('git' 'zip' 'unzip')
+source=('hawkthorne.desktop'
+ $pkgname::git+https://github.com/hawkthorne/hawkthorne-journey.git)
+sha256sums=('bb4d44614e868585b9079cdf1de5039c73bbfe433faf13c9fc7d3c27c254527e'
+ SKIP)
+
+pkgver() {
+ cd $pkgname
+ git describe | sed 's/-/_/g'
+}
+
+build() {
+ cd $pkgname
+ make love
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin/"
+ echo -e '#!/bin/bash\nlove /usr/share/hawkthorne-journey/hawkthorne.love\n' > "$pkgdir/usr/bin/hawkthorne"
+ chmod +x "$pkgdir/usr/bin/hawkthorne"
+
+ install -Dm644 "$srcdir/hawkthorne.desktop" "$pkgdir/usr/share/applications/hawkthorne.desktop"
+ install -Dm644 "$srcdir/$pkgname/src/images/menu/logo.png" "$pkgdir/usr/share/pixmaps/hawkthorne.png"
+ install -dm755 "$pkgdir/usr/share/hawkthorne-journey/"
+ install -Dm755 "$srcdir/$pkgname/build/hawkthorne.love" "$pkgdir/usr/share/hawkthorne-journey/"
+}
diff --git a/hawkthorne.desktop b/hawkthorne.desktop
new file mode 100644
index 000000000000..179251ce529f
--- /dev/null
+++ b/hawkthorne.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Hawkthorne Journey
+GenericName=hawkthorne
+Comment=2D platformer based on Community's Digital Estate Planning episode.
+Icon=/usr/share/pixmaps/hawkthorne.png
+Type=Application
+Categories=Games
+Exec=/usr/bin/hawkthorne
+Terminal=false