summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCthuflu2019-01-28 13:49:00 -0500
committerCthuflu2019-01-28 13:49:00 -0500
commitaa57d26aae8a15ed2d1163d6c841a8733b8954df (patch)
treeb760c8c74d8c8f2bf5c4a90600ae54e83c2faea0
parentf67545b015ce76072ac3c2ec5ad85ba591f55989 (diff)
downloadaur-aa57d26aae8a15ed2d1163d6c841a8733b8954df.tar.gz
Updated md5sum of haxe.sh, fixed install location in package() to /usr
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7114db060546..86b06f6d383c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Tom Bebbington <tophattedcoder@gmail.com>
pkgname=haxe-git
-pkgver=16771
+pkgver=16779
pkgrel=1
pkgdesc="An open-source high-level multiplatform programming language and compiler that can produce applications and source code for many different platforms from a single code-base"
arch=('i686' 'x86_64')
@@ -17,7 +17,7 @@ options=('!strip' 'emptydirs' '!makeflags')
install=haxe.install
source=('haxe.sh'
"haxe::git+https://github.com/HaxeFoundation/haxe")
-md5sums=('2744426baf31e3602473bcb8397947e3'
+md5sums=('977476c8fc1dfc0acbb05bd22f9136b0'
'SKIP')
_gitmod=haxe
@@ -52,8 +52,8 @@ build() {
msg "Git commit # is ${pkgver}. Starting build..."
msg "Building haxe..." && make || return 1
msg2 "done."
- msg "Generating Manual page..." && help2man haxe -v -version -h -help --no-discard-stderr -o ../haxe-manual || return 1
- msg2 "done."
+# msg "Generating Manual page..." && help2man haxe -v -version -h -help --no-discard-stderr -o ../haxe-manual || return 1
+# msg2 "done."
_res=$?
if [ $_res -eq 0 ]; then _msg="done."; else _msg="failed."; fi
echo && msg2 $_msg
@@ -64,12 +64,11 @@ package() {
cd $srcdir/$_gitmod
mkdir -p $pkgdir/usr/bin
mkdir -p $pkgdir/usr/lib
- env HAXE_STD_PATH=$srcdir/$_gitmod/std make INSTALL_DIR="$pkgdir/usr" install
+ make INSTALL_DIR="$pkgdir/usr" install #env HAXE_STD_PATH=$srcdir/$_gitmod/std make INSTALL_DIR="$pkgdir/usr" install
mkdir -p $pkgdir/etc/profile.d
cp $srcdir/haxe.sh $pkgdir/etc/profile.d
mkdir -p $pkgdir/usr/share/licenses/haxe-git
cp $srcdir/$_gitmod/extra/LICENSE.txt $pkgdir/usr/share/licenses/haxe-git/LICENSE
- mkdir -p $pkgdir/usr/share/man/man1
- cp $srcdir/haxe-manual $pkgdir/usr/share/man/man1/haxe.1
- install --mode=755 "$srcdir/$_gitmod"/haxe "$pkgdir"/usr/bin/
+# mkdir -p $pkgdir/usr/share/man/man1
+# cp $srcdir/haxe-manual $pkgdir/usr/share/man/man1/haxe.1
}