summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFeodor Alexeev2015-08-18 02:21:52 +0500
committerFeodor Alexeev2015-08-18 02:21:52 +0500
commite8395105b1e16939728268d9c126bc9b1d27681b (patch)
treefe185029cffb567c562bbf06990f08319d302ad5
parent2f861f3908432ef11c2c1657a9e84bc16a529643 (diff)
downloadaur-e8395105b1e16939728268d9c126bc9b1d27681b.tar.gz
Fix pkgdesc
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD32
2 files changed, 5 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b1b108ae85d..9a4f546107c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = hayai-git
- pkgdesc = Benchmark framework for c++ inspired by googletest
+ pkgdesc = Benchmarking framework for c++ inspired by googletest
pkgver = r128.680064a
pkgrel = 1
url = https://github.com/nickbruun/hayai
diff --git a/PKGBUILD b/PKGBUILD
index d0948db7c7b3..5557dbbb951a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,8 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
-# The following guidelines are specific to BZR, GIT, HG and SVN packages.
-# Other VCS sources are not natively supported by makepkg yet.
-
-# Maintainer: Feodor Alexeev <feodor.alexeev@gmail.com>
-pkgname=hayai-git # '-bzr', '-git', '-hg' or '-svn'
+# Maintainer: Feodor Alexeev aka moskupols <feodor.alexeev@gmail.com>
+pkgname=hayai-git
pkgver=r128.680064a
pkgrel=1
-pkgdesc="Benchmark framework for c++ inspired by googletest"
+pkgdesc="Benchmarking framework for c++ inspired by googletest"
arch=('any')
url="https://github.com/nickbruun/hayai"
license=('unknown')
@@ -29,33 +21,18 @@ md5sums=('SKIP')
BUILDENV+=('!check')
-# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
-# a description of each element in the source array.
-
pkgver() {
cd "$srcdir/${pkgname%-git}"
-
-
# The examples below are not absolute and need to be adapted to each repo. The
# primary goal is to generate version numbers that will increase according to
# pacman's version comparisons with later commits to the repo. The format
# VERSION='VER_NUM.rREV_NUM.HASH', or a relevant subset in case VER_NUM or HASH
# are not available, is recommended.
-
-# Bazaar
- # printf "r%s" "$(bzr revno)"
-
# Git, tags available
# printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
# Git, no tags available
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-
-# Mercurial
- # printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
-
-# Subversion
- # printf "r%s" "$(svnversion | tr -d 'A-z')"
}
prepare() {
@@ -65,8 +42,6 @@ prepare() {
build() {
cd "$srcdir/${pkgname%-git}"
- # ./autogen.sh
- # ./configure --prefix=/usr
cmake -D CMAKE_INSTALL_PREFIX=/usr .
make
}
@@ -80,3 +55,4 @@ package() {
cd "$srcdir/${pkgname%-git}"
make DESTDIR="$pkgdir/" install
}
+