summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAUR Wolfbot2023-07-22 19:01:24 +0200
committerAUR Wolfbot2023-07-22 19:01:24 +0200
commit26f093f00e4f16eb7b2b444f0be0a68e9a09a4da (patch)
tree11c1535697cd8e49b52df59a3c2abd2d2909b804
parent8c616dc47d39244ac5520f43776d463eec846182 (diff)
downloadaur-26f093f00e4f16eb7b2b444f0be0a68e9a09a4da.tar.gz
PKGBUILD: swichtes source to talonius
-rw-r--r--PKGBUILD24
1 files changed, 16 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 52e1f01487ba..83a56b8a3acc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,39 @@
# Maintainer: wahrwolf <wahrwolf[ät]wolfpit.net
-# Contributor: MayeulC
+# Contributor: talonius
+# Contributor: Brian Schkerke
pkgname=hb-downloader
pkgver=0.5.0h
pkgrel=8
pkgdesc="An unofficial library for querying the Humble Bundle API"
arch=('any')
-url="https://github.com/saik0/humblebundle-python"
+url="https://github.com/talonius/hb-downloader"
+
+commit="ebbc91293c4acfc158be2100689632620fb60e50"
+
license=('MIT')
depends=('python-requests' 'python-pyaml')
makedepends=('python-setuptools')
options=(!emptydirs)
-source=("$pkgname-$pkgver::https://github.com/wahrwolf/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('941ee284114b48aca690896913c3bf631ac346cd481db83825edd192c482887f')
+source=("$pkgname-$pkgver::https://github.com/talonius/hb-downloader/archive/$commit.zip")
+sha256sums=('f11be30faaff16d31f06b07b72eecb35cb57195413b8ec4b88a552621b66d6c1')
+
+prepare() {
+ cd "$pkgname-$commit"
+ cp hb-downloader-settings.example.yaml hb-downloader-settings.yaml
+}
build() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$commit"
python setup.py build
- python setup.py test
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$commit"
install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
install -Dm 644 hb-downloader-settings.yaml -T "$pkgdir/etc/hb_downloader.yaml"
install -Dm 755 hb-downloader.py -T "$pkgdir/usr/bin/hb-downloader"
- python setup.py install --root="$pkgdir/"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}