summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAUR Wolfbot2023-07-22 19:56:56 +0200
committerAUR Wolfbot2023-07-22 19:56:56 +0200
commit843f774259b23824d7989b9b91c701325262c85a (patch)
tree648ccc1c0e9c17c2fe4f09bcc65b6860127cdc47
parent26f093f00e4f16eb7b2b444f0be0a68e9a09a4da (diff)
downloadaur-843f774259b23824d7989b9b91c701325262c85a.tar.gz
adds patch to remove logging to file
-rw-r--r--PKGBUILD16
-rw-r--r--remove-logging-to-file.patch5
2 files changed, 17 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83a56b8a3acc..aad14d3972c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=hb-downloader
pkgver=0.5.0h
-pkgrel=8
+pkgrel=9
pkgdesc="An unofficial library for querying the Humble Bundle API"
arch=('any')
url="https://github.com/talonius/hb-downloader"
@@ -15,11 +15,19 @@ license=('MIT')
depends=('python-requests' 'python-pyaml')
makedepends=('python-setuptools')
options=(!emptydirs)
-source=("$pkgname-$pkgver::https://github.com/talonius/hb-downloader/archive/$commit.zip")
-sha256sums=('f11be30faaff16d31f06b07b72eecb35cb57195413b8ec4b88a552621b66d6c1')
+source=(
+ "$pkgname-$pkgver::https://github.com/talonius/hb-downloader/archive/$commit.zip"
+ "remove-logging-to-file.patch"
+)
+sha256sums=(
+ 'f11be30faaff16d31f06b07b72eecb35cb57195413b8ec4b88a552621b66d6c1'
+ '2d60de18919d1dcd20c9fc2571c8905f40edffde229d37b074fdd19a8a4c4028'
+)
prepare() {
+ ls
cd "$pkgname-$commit"
+ patch hb_downloader/logger.py "$srcdir/remove-logging-to-file.patch"
cp hb-downloader-settings.example.yaml hb-downloader-settings.yaml
}
@@ -32,7 +40,7 @@ package() {
cd "$pkgname-$commit"
install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
- install -Dm 644 hb-downloader-settings.yaml -T "$pkgdir/etc/hb_downloader.yaml"
+ install -Dm 644 hb-downloader-settings.yaml -T "$pkgdir/etc/hb-downloader-settings.yaml"
install -Dm 755 hb-downloader.py -T "$pkgdir/usr/bin/hb-downloader"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
diff --git a/remove-logging-to-file.patch b/remove-logging-to-file.patch
new file mode 100644
index 000000000000..cf91adf6de7a
--- /dev/null
+++ b/remove-logging-to-file.patch
@@ -0,0 +1,5 @@
+33,36d32
+< # Print the output also to a logfile
+< logfile = open("hb-downloader_" + time.strftime("%Y-%m-%d") + ".log", 'a')
+< print(formatted_message, file = logfile)
+< logfile.close()