summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Dahmen2019-02-09 00:46:08 +0100
committerVincent Dahmen2019-02-09 12:14:54 +0100
commitfdbf9a6b9f4f1312c171212402cf3f45986347b5 (patch)
treec86b2aaa1a28703bf49fb2fb060b5f6cda340664
downloadaur-fdbf9a6b9f4f1312c171212402cf3f45986347b5.tar.gz
init
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29715911b957
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = hb-downloader
+ pkgdesc = An unofficial library for querying the Humble Bundle API
+ pkgver = 0.5.0h
+ pkgrel = 7
+ url = https://github.com/saik0/humblebundle-python
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-requests
+ depends = python-pyaml
+ options = !emptydirs
+ source = hb-downloader-0.5.0h::https://github.com/wahrwolf/hb-downloader/archive/v0.5.0h.tar.gz
+ sha256sums = 941ee284114b48aca690896913c3bf631ac346cd481db83825edd192c482887f
+
+pkgname = hb-downloader
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06932c73c2b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: wahrwolf <wahrwolf[ät]wolfpit.net
+# Contributor: MayeulC
+
+pkgname=hb-downloader
+pkgver=0.5.0h
+pkgrel=7
+pkgdesc="An unofficial library for querying the Humble Bundle API"
+arch=('any')
+url="https://github.com/saik0/humblebundle-python"
+license=('MIT')
+depends=('python-requests' 'python-pyaml')
+makedepends=('python-setuptools')
+options=(!emptydirs)
+source=("$pkgname-$pkgver::https://github.com/wahrwolf/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('941ee284114b48aca690896913c3bf631ac346cd481db83825edd192c482887f')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+ python setup.py test
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+ install -Dm 644 hb-downloader-settings.yaml -T "$pkgdir/etc/hb_downloader.yaml"
+ install -Dm 755 hb-downloader.py -T "$pkgdir/usr/bin/hb_downloader"
+
+ python setup.py install --root="$pkgdir/"
+}