summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErazem Kokot2019-02-26 17:57:11 +0100
committerErazem Kokot2019-02-26 17:57:11 +0100
commit575feba45187691b8d3d35a615f5e062dddcbd76 (patch)
treed7fad9bb3f8f3735cfc0c2bd16b662185432648e
parent5cddaefa84e118a0459e824f4899c679c92a80e3 (diff)
downloadaur-575feba45187691b8d3d35a615f5e062dddcbd76.tar.gz
Update to 2.0.4 and make package instead of download
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
2 files changed, 18 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 244cd486a7da..80f235202287 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = hblock
pkgdesc = An adblocker that creates a hosts file from automatically downloaded blacklists
- pkgver = 2.0.0
+ pkgver = 2.0.4
pkgrel = 1
url = https://github.com/hectorm/hblock
arch = any
license = MIT
- source = https://raw.githubusercontent.com/hectorm/hblock/v2.0.0/hblock
- sha256sums = fc2d59f38d3db4c1d39def1f2360299472ae209fb1d60b28121d8727d38bf7a8
+ source = https://github.com/hectorm/hblock/archive/v2.0.4.tar.gz
+ sha256sums = 5363ed1aa7c9acb798591949f516d122e8d40100ae87055bfdba937c6c9bf108
pkgname = hblock
diff --git a/PKGBUILD b/PKGBUILD
index 604192d96b46..3b76f9f24196 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,26 @@
# Maintainer: Erazem Kokot <contact at erazem dot eu>
pkgname='hblock'
-pkgver=2.0.0
+pkgver=2.0.4
pkgrel=1
pkgdesc='An adblocker that creates a hosts file from automatically downloaded blacklists'
arch=('any')
url='https://github.com/hectorm/hblock'
license=('MIT')
-sha256sums=('fc2d59f38d3db4c1d39def1f2360299472ae209fb1d60b28121d8727d38bf7a8')
-source=("https://raw.githubusercontent.com/hectorm/${pkgname}/v${pkgver}/${pkgname}")
+sha256sums=('5363ed1aa7c9acb798591949f516d122e8d40100ae87055bfdba937c6c9bf108')
+source=("https://github.com/hectorm/${pkgname}/archive/v${pkgver}.tar.gz")
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ make
+}
+
+check() {
+ cd "${pkgname}-${pkgver}"
+ make -k check
+}
package() {
- install -Dm755 "${pkgname}" "${pkgdir}/usr/local/bin/${pkgname}"
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}/" install
}