summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErazem Kokot2018-12-15 20:51:03 +0100
committerErazem Kokot2018-12-15 20:51:03 +0100
commit5cddaefa84e118a0459e824f4899c679c92a80e3 (patch)
tree7096d74c8293218e51beea29264d32084d2e5cad
downloadaur-5cddaefa84e118a0459e824f4899c679c92a80e3.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD15
3 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..244cd486a7da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = hblock
+ pkgdesc = An adblocker that creates a hosts file from automatically downloaded blacklists
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/hectorm/hblock
+ arch = any
+ license = MIT
+ source = https://raw.githubusercontent.com/hectorm/hblock/v2.0.0/hblock
+ sha256sums = fc2d59f38d3db4c1d39def1f2360299472ae209fb1d60b28121d8727d38bf7a8
+
+pkgname = hblock
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ccac7d848437
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.pkg.tar
+hblock
+todo.txt
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..604192d96b46
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,15 @@
+# Maintainer: Erazem Kokot <contact at erazem dot eu>
+
+pkgname='hblock'
+pkgver=2.0.0
+pkgrel=1
+pkgdesc='An adblocker that creates a hosts file from automatically downloaded blacklists'
+arch=('any')
+url='https://github.com/hectorm/hblock'
+license=('MIT')
+sha256sums=('fc2d59f38d3db4c1d39def1f2360299472ae209fb1d60b28121d8727d38bf7a8')
+source=("https://raw.githubusercontent.com/hectorm/${pkgname}/v${pkgver}/${pkgname}")
+
+package() {
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/local/bin/${pkgname}"
+}