summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErazem Kokot2019-03-16 16:21:29 +0100
committerErazem Kokot2019-03-16 16:21:29 +0100
commit778192cbf0d4e1af409cabec38dcd0164c5b71b6 (patch)
treef9e27a4bcae00a6c2f9b0a3c5d29a0bb5bee696d
parentc23739c5b69551f8e71d1cd117535b9797a99705 (diff)
downloadaur-778192cbf0d4e1af409cabec38dcd0164c5b71b6.tar.gz
Fix packaging problem and add gitignore
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD10
3 files changed, 13 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6597f3cd564..351e40773eda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hblock
pkgdesc = An adblocker that creates a hosts file from automatically downloaded blacklists
pkgver = 2.0.5
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/hectorm/hblock
arch = any
license = MIT
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..beef0b41367e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# makepkg dirs
+pkg/
+src/
+
+# source files
+*.tar.gz
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index d892b556d554..49488a471472 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
pkgname='hblock'
pkgver=2.0.5
-pkgrel=3
+pkgrel=4
pkgdesc='An adblocker that creates a hosts file from automatically downloaded blacklists'
arch=('any')
url='https://github.com/hectorm/hblock'
license=('MIT')
sha256sums=('2de6856a863e1901d03f6566ed7b425778e65484b7f62c2ebe7c2b2f6fd23363')
-source=("https://github.com/hectorm/$pkgname/archive/v$pkgver.tar.gz")
+source=("https://github.com/hectorm/${pkgname}/archive/v${pkgver}.tar.gz")
build() {
- cd "$pkgname-$pkgver"
+ cd "${pkgname}-${pkgver}"
make
}
package() {
- cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}/" SKIP_SERVICE_START=1 install
}