summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Krüger2017-09-26 07:38:27 +0200
committerMike Krüger2017-09-26 07:38:27 +0200
commit824704b5e8a567772bf7400321354c5711537ea0 (patch)
tree2444bc9c7a1f601d667bd0c02c4fd9d2bebf57ec
downloadaur-824704b5e8a567772bf7400321354c5711537ea0.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..28bed6f845d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = hblox-git
+ pkgdesc = hblox is an command line ad blocker for Linux using the hosts file. (written in Python 3)
+ pkgver = r8.65d2d86
+ pkgrel = 1
+ url = https://github.com/memoryleakx/hblox
+ arch = any
+ license = GPL3
+ depends = python-clint>=0.5
+ depends = python-urllib3>=1.22
+ depends = sqlite>=3.20
+ source = git+https://github.com/memoryleakx/hblox.git
+ sha256sums = SKIP
+
+pkgname = hblox-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a43282c9f2ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Mike Krüger <mikekrueger81[at]gmail.com>
+
+pkgname=hblox-git
+_gitname=hblox
+pkgdesc='hblox is an command line ad blocker for Linux using the hosts file. (written in Python 3)'
+pkgver=r8.65d2d86
+pkgrel=1
+arch=('any')
+url="https://github.com/memoryleakx/hblox"
+license=('GPL3')
+depends=('python-clint>=0.5'
+ 'python-urllib3>=1.22'
+ 'sqlite>=3.20')
+source=("git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $_gitname
+ install -Dm755 "hblox" "$pkgdir/usr/bin/hblox"
+}