summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Turner2021-12-27 18:58:23 -0500
committerWilliam Turner2021-12-27 18:58:23 -0500
commit3a728594a071c3fbed351fb8fb901103eff45bce (patch)
treec1a6b133d2799b38ef26533e49a4968875d2573b
parent2c62223f74b2aa1bb2ebfd11acd92ac6b8a9f33f (diff)
downloadaur-hboxc.tar.gz
upgpkg: hboxc 0.0.17-1
upstream release
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD37
2 files changed, 22 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50f689754db2..76e170fd3726 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
pkgbase = hboxc
pkgdesc = Virtual Infrastructure Manager for VirtualBox - Client
- pkgver = 0.0.13
+ pkgver = 0.0.17
pkgrel = 1
url = https://kamax.io/hbox/
arch = x86_64
license = GPL3
- depends = java-runtime>=7
- depends = bash
- source = https://github.com/hyperbox/hyperbox/releases/download/0.0.13/hbox-0.0.13-linux_amd64-client.zip
- sha256sums = 08a7363c5334ff44053462324983a53d7e605e72ffdad078276fbcf4a11372c1
+ depends = java-runtime>=8
+ source = https://github.com/hyperbox/hyperbox/releases/download/v0.0.17/hbox-client-0.0.17-linux.zip
+ sha256sums = 8e01b7f057f192016d23d033fc0102acd9d9d28f90fe152b1712a0839a406551
pkgname = hboxc
-
diff --git a/PKGBUILD b/PKGBUILD
index d22c2b4a4607..3763a48efdbb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,33 @@
# Maintainer: William Turner <willtur.will@gmail.com>
+_name=hyperbox
pkgname=hboxc
-pkgver=0.0.13
+pkgver=0.0.17
pkgrel=1
-pkgdesc='Virtual Infrastructure Manager for VirtualBox - Client'
+pkgdesc="Virtual Infrastructure Manager for VirtualBox - Client"
arch=('x86_64')
url='https://kamax.io/hbox/'
license=('GPL3')
-depends=('java-runtime>=7' 'bash')
-source=("https://github.com/hyperbox/hyperbox/releases/download/${pkgver}/hbox-${pkgver}-linux_amd64-client.zip")
-sha256sums=('08a7363c5334ff44053462324983a53d7e605e72ffdad078276fbcf4a11372c1')
+depends=('java-runtime>=8')
+source=("https://github.com/hyperbox/${_name}/releases/download/v${pkgver}/hbox-client-${pkgver}-linux.zip")
+sha256sums=('8e01b7f057f192016d23d033fc0102acd9d9d28f90fe152b1712a0839a406551')
package() {
- cd "${srcdir}"
-
# copy package files
- install -d -m755 "${pkgdir}/opt/hboxc"
- cp -r bin doc hyperbox icons modules lib "${pkgdir}/opt/hboxc"
- chmod 755 "${pkgdir}/opt/hboxc/hyperbox"
+ install -d -m755 "${pkgdir}/opt/${pkgname}"
+ cp -r bin icons lib "${pkgdir}/opt/${pkgname}/"
+
+ # Installed patched launch script
+ sed "s;HBOX_CLIENT_BASE_DIR=.*;HBOX_CLIENT_BASE_DIR=/opt/${pkgname};" hyperbox > "${pkgdir}/opt/${pkgname}/hyperbox"
+ chmod 755 "${pkgdir}/opt/${pkgname}/hyperbox"
- # create the start script in /usr/bin
+ # Add symlinks in path
install -d -m755 "${pkgdir}/usr/bin"
- sed 's|export HBOX_CLIENT_BASE_DIR=.*|export HBOX_CLIENT_BASE_DIR=/opt/hboxc|' hyperbox > "${pkgdir}/usr/bin/hboxc"
- chmod 755 "${pkgdir}/usr/bin/hboxc"
+ ln -s "/opt/${pkgname}/hyperbox" "${pkgdir}/usr/bin/hyperbox"
+ ln -s "/opt/${pkgname}/hyperbox" "${pkgdir}/usr/bin/hboxc"
# add shortcut stuff
install -D -m644 hyperbox-client.desktop "${pkgdir}/usr/share/applications/hyperbox-client.desktop"
- echo "Path=/opt/hboxc" >> "${pkgdir}/usr/share/applications/hyperbox-client.desktop"
- echo "Exec=/opt/hboxc/hyperbox" >> "${pkgdir}/usr/share/applications/hyperbox-client.desktop"
- echo "Icon=/opt/hboxc/icons/hyperbox.ico" >> "${pkgdir}/usr/share/applications/hyperbox-client.desktop"
-
- # add license
- install -D -m644 doc/manual/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ echo "Path=/opt/${pkgname}" >> "${pkgdir}/usr/share/applications/hyperbox-client.desktop"
+ echo "Exec=/opt/${pkgname}/hyperbox" >> "${pkgdir}/usr/share/applications/hyperbox-client.desktop"
+ echo "Icon=/opt/${pkgname}/icons/hyperbox.ico" >> "${pkgdir}/usr/share/applications/hyperbox-client.desktop"
}