summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneeshy2020-03-03 23:55:45 -0500
committerneeshy2020-03-07 14:29:30 -0500
commit8fd409ebfd98bcbd0e7416e77831ae448df35cf0 (patch)
tree3c5712a6f0fb7b7512ab76021586de23e95930fb
parent184fd0b24aa3220571e99910b3021c1af56fa555 (diff)
downloadaur-8fd409ebfd98bcbd0e7416e77831ae448df35cf0.tar.gz
Cleanup
Consistent style across project Remove extraneous dependencies Update packages Update checksums and .SRCINFO Specify proper license Fix prefixes Prefer make to ninja Much more TODO: miopen, rocm-cmake{,-git}, rock-dkms{,-git}, Remove duplicates in makedepends and depends git submodules
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7efd70733004..c0920bc2383e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,10 +5,9 @@ pkgbase = hcc
url = https://github.com/RadeonOpenCompute/hcc
arch = x86_64
license = custom:NCSAOSL
- makedepends = git
makedepends = cmake
makedepends = python
- depends = rocr-runtime>=3.0.0
+ depends = rocr-runtime>=3.1.0
depends = z3
options = !staticlibs
options = strip
diff --git a/PKGBUILD b/PKGBUILD
index cb68a21bcf7b..2be73530dd1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,8 @@ pkgdesc="HCC is an Open Source, Optimizing C++ Compiler for Heterogeneous Comput
arch=('x86_64')
url="https://github.com/RadeonOpenCompute/hcc"
license=('custom:NCSAOSL')
-depends=('rocr-runtime>=3.0.0' 'z3')
-makedepends=('git' 'cmake' 'python')
+depends=("rocr-runtime>=$pkgver" 'z3')
+makedepends=('cmake' 'python')
options=(!staticlibs strip)
source=("hcc-roc-hcc-$pkgver.tar.gz::https://github.com/RadeonOpenCompute/hcc/archive/roc-hcc-$pkgver.tar.gz"
"llvm-project-roc-hcc-$pkgver.tar.gz::https://github.com/RadeonOpenCompute/llvm-project/archive/roc-hcc-$pkgver.tar.gz"