summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-01-03 09:46:57 -0500
committeracxz2020-01-03 09:46:57 -0500
commit35542c3b99c6bef4d3929314aa07c2151acfbd93 (patch)
tree684be9db04739c3672516a7b6d227ae6165bc6b5
parentc5caa43a4b98447bc18f2df7c6a1e13657340074 (diff)
downloadaur-35542c3b99c6bef4d3929314aa07c2151acfbd93.tar.gz
fix up install procedure
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
2 files changed, 21 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51ded72ed6ce..f2da41da2b8c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hcc-git
pkgdesc = C++ Compiler for Heterogeneous Compute
- pkgver = r7685.e8488139
+ pkgver = r7687.4fc4913a
pkgrel = 1
url = https://github.com/RadeonOpenCompute/hcc
arch = x86_64
@@ -11,6 +11,10 @@ pkgbase = hcc-git
provides = hcc
conflicts = hcc
source = git+https://github.com/RadeonOpenCompute/hcc.git
+ source = git+https://github.com/RadeonOpenCompute/llvm-project.git
+ source = git+https://github.com/RadeonOpenCompute/ROCm-Device-Libs.git
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = hcc-git
diff --git a/PKGBUILD b/PKGBUILD
index 9a3c49b53858..b7368863056e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=hcc-git
-pkgver=r7685.e8488139
+pkgver=r7687.4fc4913a
pkgrel=1
pkgdesc="C++ Compiler for Heterogeneous Compute"
url="https://github.com/RadeonOpenCompute/hcc"
@@ -10,14 +10,26 @@ makedepends=(git cmake rocr-runtime)
provides=('hcc')
conflicts=('hcc')
_name=hcc
-source=("git+https://github.com/RadeonOpenCompute/hcc.git")
-sha256sums=("SKIP")
+source=("git+https://github.com/RadeonOpenCompute/hcc.git"
+ "git+https://github.com/RadeonOpenCompute/llvm-project.git"
+ "git+https://github.com/RadeonOpenCompute/ROCm-Device-Libs.git")
+sha256sums=("SKIP"
+ "SKIP"
+ "SKIP")
pkgver() {
cd "$_name"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "${srcdir}/${_name}"
+ git submodule init
+ git config submodule.llvm-project.git.url "${srcdir}/llvm-project"
+ git config submodule.ROCm-Device-Libs.git.url "${srcdir}/rocdl"
+ git submodule update
+}
+
build() {
cd "${srcdir}/${_name}"
@@ -27,8 +39,7 @@ build() {
cd "${srcdir}/${_name}/build"
cmake .. -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_INSTALL_PREFIX="${pkgdir}/opt/rocm/hcc"
make
}