summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcarrot2023-12-18 12:04:05 +0800
committercarrot2023-12-18 12:04:05 +0800
commit970c378185829972fda324b8a9d7bdaed7ce90dd (patch)
tree23f49f3878fb3e04a219e3353a4d9bcf71d14343
parent9129b9f280845b4c39e5ce96db416fca32519436 (diff)
downloadaur-970c378185829972fda324b8a9d7bdaed7ce90dd.tar.gz
1.18.4-7
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD29
2 files changed, 19 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44fb030ba93c..bd6a5fa3ebdf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = hcclient-latex
pkgdesc = A terminal client for hack.chat, with LaTeX support
pkgver = 1.18.4
- pkgrel = 6
+ pkgrel = 7
url = https://github.com/AnnikaV9/hcclient
arch = x86_64
license = Unlicense
makedepends = python-pip
makedepends = python-wheel
- makedepends = python-poetry
depends = python
provides = hcclient
conflicts = hcclient
- source = v1.18.4.tar.gz::https://github.com/AnnikaV9/hcclient/archive/refs/tags/v1.18.4.tar.gz
+ noextract = hcclient-1.18.4-py3-none-any.whl
+ source = https://github.com/AnnikaV9/hcclient/releases/download/v1.18.4/hcclient-1.18.4-py3-none-any.whl
+ source = hcclient-latex-1.18.4.tar.gz::https://github.com/AnnikaV9/hcclient/archive/refs/tags/v1.18.4.tar.gz
+ sha256sums = 6805fe0ae87daa677a8efb834d38c7964aeccc9fc49146c5e2f789499ece7731
sha256sums = 41140c9bbebf4571c410af485c0c524157d4bf51c08bd6197666af9ff09cea91
pkgname = hcclient-latex
diff --git a/PKGBUILD b/PKGBUILD
index b3dc310b01b5..18fe97e5b4a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=hcclient-latex
pkgver=1.18.4
-pkgrel=6
+pkgrel=7
pkgdesc="A terminal client for hack.chat, with LaTeX support"
arch=("x86_64")
url="https://github.com/AnnikaV9/hcclient"
@@ -10,28 +10,27 @@ license=("Unlicense")
provides=("hcclient")
conflicts=("hcclient")
depends=("python")
-makedepends=("python-pip" "python-wheel" "python-poetry")
-source=("v${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('41140c9bbebf4571c410af485c0c524157d4bf51c08bd6197666af9ff09cea91')
+makedepends=("python-pip" "python-wheel")
+source=(
+ "${url}/releases/download/v${pkgver}/hcclient-$pkgver-py3-none-any.whl"
+ "${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v1.18.4.tar.gz"
+)
+noextract=("hcclient-${pkgver}-py3-none-any.whl")
+sha256sums=(
+ '6805fe0ae87daa677a8efb834d38c7964aeccc9fc49146c5e2f789499ece7731'
+ '41140c9bbebf4571c410af485c0c524157d4bf51c08bd6197666af9ff09cea91'
+)
build() {
- cd "${srcdir}/hcclient-${pkgver}"
- sed -i "s/-git//g" src/hcclient/__main__.py \
- src/hcclient/client.py \
- src/hcclient/config.py \
- src/hcclient/formatter.py \
- src/hcclient/hook.py
python -m venv iso-env
- python -m venv .venv
- poetry build -f wheel --no-ansi --no-interaction
- ./iso-env/bin/pip install --disable-pip-version-check --no-color "dist/hcclient-${pkgver}-py3-none-any.whl[latex]"
+ ./iso-env/bin/pip install --disable-pip-version-check --no-color "hcclient-${pkgver}-py3-none-any.whl[latex]"
./iso-env/bin/pip uninstall setuptools pip -y --quiet
- rm iso-env/bin/{activate*,Activate*}
+ rm -f iso-env/bin/{activate,activate.*,Activate,Activate.*}
}
package() {
install -Dm755 "${srcdir}/hcclient-${pkgver}/scripts/arch_entry.py" "${pkgdir}/usr/bin/hcclient"
mkdir "${pkgdir}/opt"
- cp -a "${srcdir}/hcclient-${pkgver}/iso-env" "${pkgdir}/opt/hcclient"
+ cp -a "${srcdir}/iso-env" "${pkgdir}/opt/hcclient"
install -Dm644 "${srcdir}/hcclient-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/hcclient/LICENSE"
}