summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornull2016-01-05 19:36:28 -0500
committernull2016-01-05 19:36:28 -0500
commit49693386e2f3ad466ec668f46da7b53fb0a864ac (patch)
tree86ae181668339c2fed5ca4bc8fe86cd07d5f76f8
downloadaur-49693386e2f3ad466ec668f46da7b53fb0a864ac.tar.gz
First commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD54
-rw-r--r--hda-jack-retask-bzr.install9
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d3ce5092e375
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Jan 6 00:36:19 UTC 2016
+pkgbase = hda-jack-retask-bzr
+ pkgdesc = Retask your jack plugs (eg. turn your microphone jack plug into a headphone one).
+ pkgver = 10
+ pkgrel = 1
+ url = https://code.launchpad.net/~diwic/+junk/hda-jack-retask
+ install = hda-jack-retask-bzr.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = bzr
+ depends = gtk3
+ depends = desktop-file-utils
+
+pkgname = hda-jack-retask-bzr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..262095767d40
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Julien Nicoulaud <julien.nicoulaud@gmail.com>
+# Source: https://github.com/nicoulaj/archlinux-packages
+pkgname=hda-jack-retask-bzr
+_pkgname=hda-jack-retask
+pkgver=10
+pkgrel=1
+pkgdesc="Retask your jack plugs (eg. turn your microphone jack plug into a headphone one)."
+arch=(i686 x86_64)
+url="https://code.launchpad.net/~diwic/+junk/hda-jack-retask"
+license=(GPL2)
+depends=(gtk3 desktop-file-utils)
+makedepends=(bzr)
+install=${pkgname}.install
+
+_bzrtrunk="https://code.launchpad.net/~diwic/+junk/hda-jack-retask"
+_bzrmod="hda-jack-retask"
+
+build() {
+ cd "${srcdir}"
+
+ msg2 "Connecting to Bazaar server and checking out..."
+ if [ -d ${_bzrmod} ] ; then
+ cd ${_bzrmod} && bzr --no-plugins pull ${_bzrtrunk} -q -r ${pkgver}
+ msg2 "Local files are up to date."
+ else
+ bzr --no-plugins branch ${_bzrtrunk} ${_bzrmod} -q -r ${pkgver}
+ fi
+ msg2 "Bazaar checkout done or server timeout."
+
+ msg2 "Building..."
+ cd "${srcdir}/${_bzrmod}"
+ make || return 1
+
+ msg2 "Generate desktop application entry..."
+ cat > "${srcdir}"/${_pkgname}.desktop << EOF
+[Desktop Entry]
+Name=HDA jack retask
+Comment=${pkgdesc}
+Exec=/usr/bin/hda-jack-retask
+Terminal=false
+Icon=applications-system
+Type=Application
+Categories=Settings;HardwareSettings;
+EOF
+}
+
+package() {
+ msg2 "Installing..."
+ cd "${srcdir}/${_bzrmod}"
+ make install DESTDIR="${pkgdir}"
+
+ msg2 "Install desktop application entry in /usr/share/applications..."
+ install -Dm644 "${srcdir}"/${_pkgname}.desktop "${pkgdir}"/usr/share/applications/${_pkgname}.desktop
+} \ No newline at end of file
diff --git a/hda-jack-retask-bzr.install b/hda-jack-retask-bzr.install
new file mode 100644
index 000000000000..28db455dd562
--- /dev/null
+++ b/hda-jack-retask-bzr.install
@@ -0,0 +1,9 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+# vim:set ts=2 sw=2 et: \ No newline at end of file