summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGavin Lloyd2015-06-09 17:21:02 -0700
committerGavin Lloyd2015-06-09 17:21:02 -0700
commit0e7d2023bd8cc4d939458600517952bb0512f2e2 (patch)
tree432b7c9262b05dd1fded5301aa41c10325c9b84d
downloadaur-0e7d2023bd8cc4d939458600517952bb0512f2e2.tar.gz
Init commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a3fa885c4418
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = hdaps-gl
+ pkgdesc = ThinkPad HDAPS OpenGL monitor
+ pkgver = 0.0.5
+ pkgrel = 3
+ url = http://hdaps.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = freeglut
+ source = http://downloads.sourceforge.net/sourceforge/hdaps/hdaps-gl-0.0.5.tar.gz
+ md5sums = e0924c964c70f5b4d8ee8de67108c6a9
+
+pkgname = hdaps-gl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..364d71d9f112
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Gavin Lloyd <gavinhungry@gmail.com>
+# Contributor: Tomas Kramar <kramar[dot]tomas[at]gmail[dot]com>
+
+pkgname=hdaps-gl
+pkgver=0.0.5
+pkgrel=3
+pkgdesc='ThinkPad HDAPS OpenGL monitor'
+arch=('i686' 'x86_64')
+url='http://hdaps.sourceforge.net'
+license=('GPL')
+depends=('freeglut')
+source=("http://downloads.sourceforge.net/sourceforge/hdaps/${pkgname}-${pkgver}.tar.gz")
+md5sums=('e0924c964c70f5b4d8ee8de67108c6a9')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ mkdir -p "${pkgdir}/usr/bin"
+ install hdaps-gl "${pkgdir}/usr/bin"
+}