summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlynix2015-06-08 19:54:30 +0200
committerlynix2015-06-08 19:54:30 +0200
commitd15234ae6b356db7b83ecf9c31e9d937741411c3 (patch)
tree266cd94e02cc49f154f7ee1d797f962ceb694b66
downloadaur-d15234ae6b356db7b83ecf9c31e9d937741411c3.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD24
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..25c6c6c9e9b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by makepkg 4.2.1
+# Sat May 23 22:34:56 UTC 2015
+pkgbase = hdd-spindown.sh-git
+ pkgdesc = Automatic Disk Standby using Kernel diskstats and hdparm
+ pkgver = 20150524
+ pkgrel = 1
+ url = https://github.com/lynix/hdd-spindown.sh
+ arch = any
+ license = MIT
+ depends = awk
+ depends = coreutils
+ depends = grep
+ depends = systemd
+ depends = hdparm
+ depends = util-linux
+ optdepends = smartmontools: recognizing SMART self-tests
+ source = git://github.com/lynix/hdd-spindown.sh.git
+ md5sums = SKIP
+
+pkgname = hdd-spindown.sh-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..faa04d92f255
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: lynix <lynix47@gmail.com>
+
+pkgname=hdd-spindown.sh-git
+pkgver=20150524
+pkgrel=1
+pkgdesc="Automatic Disk Standby using Kernel diskstats and hdparm"
+url="https://github.com/lynix/hdd-spindown.sh"
+arch=('any')
+license=('MIT')
+depends=('awk' 'coreutils' 'grep' 'systemd' 'hdparm' 'util-linux')
+optdepends=('smartmontools: recognizing SMART self-tests')
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+source=("git://github.com/lynix/hdd-spindown.sh.git")
+md5sums=('SKIP')
+
+package() {
+ cd "${srcdir}/${pkgname%-git}"
+ make PREFIX="${pkgdir}/usr" install
+}
+
+# vim:set ts=2 sw=2 et: