summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordesbma2017-01-13 11:31:26 +0100
committerdesbma2017-01-13 11:31:26 +0100
commitb4cd384db03fdbc2efa0b35fd742f52c0c770394 (patch)
tree947821f3821c85a0a2d63b53626fe3a5ca032e0c
downloadaur-b4cd384db03fdbc2efa0b35fd742f52c0c770394.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD24
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b73fb1c10fd4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-hddfancontrol
+ pkgdesc = Regulate fan speed according to hard drive temperature
+ pkgver = 1.2.4
+ pkgrel = 1
+ url = https://github.com/desbma/hddfancontrol
+ arch = any
+ license = GPL
+ makedepends = python-pip
+ depends = python
+ depends = hdparm
+ depends = hddtemp
+ source = hddfancontrol-1.2.4.tar.gz:https://github.com/desbma/hddfancontrol/archive/1.2.4.tar.gz
+ md5sums = 6a4fe8fb50d3d7d4ec05c329a82e5378
+
+pkgname = python-hddfancontrol
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e5ec3740fbdf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+/*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a60cce2a33e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: desbma
+pkgname=python-hddfancontrol
+pkgver=1.2.4
+pkgrel=1
+pkgdesc="Regulate fan speed according to hard drive temperature"
+arch=('any')
+_gitname='hddfancontrol'
+url="https://github.com/desbma/${_gitname}"
+license=('GPL')
+depends=('python' 'hdparm' 'hddtemp')
+makedepends=('python-pip')
+source=("${_gitname}-${pkgver}.tar.gz:https://github.com/desbma/${_gitname}/archive/${pkgver}.tar.gz")
+md5sums=('6a4fe8fb50d3d7d4ec05c329a82e5378')
+
+check() {
+ cd "${_gitname}-${pkgver}"
+ python setup.py test
+}
+
+package() {
+ cd "${_gitname}-${pkgver}"
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="${pkgdir}" --ignore-installed --no-deps -r requirements.txt
+ python setup.py install --root="${pkgdir}"
+}