summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip2016-09-29 08:07:52 +0200
committerJosip2016-09-29 08:07:52 +0200
commit4a3084c4d2e1db056b2d9fa7d3afa13dfe9c0340 (patch)
tree9fd1ce59bd93c701618dca7791fcb001a40540e0
downloadaur-4a3084c4d2e1db056b2d9fa7d3afa13dfe9c0340.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3441c0102903
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = hdepanel-git
+ pkgdesc = Qt5 based panel based on QtPanel
+ pkgver = v1.0.5.r0.gbd05f0a
+ pkgrel = 1
+ url = https://github.com/developing4all/hdepanel
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = libxcomposite
+ depends = qt5-x11extras
+ provides = hdepanel
+ conflicts = hdepanel
+ source = git+https://github.com/developing4all/hdepanel.git
+ md5sums = SKIP
+
+pkgname = hdepanel-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99e73cbf2329
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
+
+pkgname=hdepanel-git
+pkgver=v1.0.5.r0.gbd05f0a
+pkgrel=1
+pkgdesc="Qt5 based panel based on QtPanel"
+arch=('i686' 'x86_64')
+url="https://github.com/developing4all/hdepanel"
+license=('GPL2')
+depends=('libxcomposite' 'qt5-x11extras')
+makedepends=('git')
+provides=('hdepanel')
+conflicts=('hdepanel')
+source=("git+${url}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd hdepanel
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd hdepanel
+ qmake-qt5
+ make
+}
+
+package() {
+ cd hdepanel
+ install -Dm755 hdepanel "${pkgdir}/usr/bin/hdepanel"
+ install -d "${pkgdir}/usr/lib/hde/panel/plugins"
+ cp -a libhdepanel* "${pkgdir}/usr/lib"
+ cp -a plugins/lib*.so "${pkgdir}/usr/lib/hde/panel/plugins"
+}