summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavierCLL2017-05-22 23:59:12 -0500
committerXavierCLL2017-05-22 23:59:12 -0500
commit05b2686af14d803f97b8684f554b59f9445f2733 (patch)
treeec593ac208165d673cc89fdea94b1fa79df4694a
parentabde8b3cd6635874e94ed0e876e9f36d88ae6650 (diff)
downloadaur-05b2686af14d803f97b8684f554b59f9445f2733.tar.gz
added patch for build with hdf5 1.10.x, thanks to David Brown, others adjusts
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD31
-rw-r--r--patches.tar.gzbin3627 -> 4717 bytes
3 files changed, 20 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b534a68b7326..d1d2c3209da4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,20 @@
-# Generated by mksrcinfo v8
-# Mon Jul 18 23:08:00 UTC 2016
pkgbase = hdf-eos5
- pkgdesc = The HDF-EOS5 is a software library designed built on HDF5 to support the same Grid/Point/Swath functionality in HDF-EOS 2 and to the extent possible it will be built with the same calling sequences as the original HDF-EOS 2 library.
+ pkgdesc = The HDF-EOS is a software library designed built on HDF5 to support the same Grid/Point/Swath functionality in HDF-EOS 2 and to the extent possible it will be built with the same calling sequences as the original HDF-EOS 2 library.
pkgver = 1.15
- pkgrel = 4
+ pkgrel = 5
url = http://www.hdfeos.org/software/library.php
arch = i686
arch = x86_64
license = GPL
depends = szip
- depends = hdf5_18
+ depends = hdf5-cpp-fortran
depends = gdal
- depends = hdf-eos-common
options = libtool
options = staticlibs
source = ftp://edhs1.gsfc.nasa.gov/edhs/hdfeos5/latest_release/HDF-EOS5.1.15.tar.Z
source = patches.tar.gz
md5sums = 5d607a13dd42e559bfc90e278a8ec919
- md5sums = 0d0285e6f81f24a961adf9d9f84973ce
+ md5sums = e65fffc8956e953f37a767ce9782b592
pkgname = hdf-eos5
diff --git a/PKGBUILD b/PKGBUILD
index 036a34f9d0c1..981802ee81e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,30 @@
pkgname=hdf-eos5
pkgver=1.15
-pkgrel=4
-pkgdesc="The HDF-EOS5 is a software library designed built on HDF5 to support the same Grid/Point/Swath functionality in HDF-EOS 2 and to the extent possible it will be built with the same calling sequences as the original HDF-EOS 2 library."
+pkgrel=5
+pkgdesc="The HDF-EOS is a software library designed built on HDF5 to support the same Grid/Point/Swath functionality in HDF-EOS 2 and to the extent possible it will be built with the same calling sequences as the original HDF-EOS 2 library."
url="http://www.hdfeos.org/software/library.php"
license=('GPL')
arch=('i686' 'x86_64')
-depends=('szip' 'hdf5_18' 'gdal' 'hdf-eos-common')
+depends=('szip' 'hdf5-cpp-fortran' 'gdal' )
options=('libtool' 'staticlibs')
source=(ftp://edhs1.gsfc.nasa.gov/edhs/hdfeos5/latest_release/HDF-EOS5.$pkgver.tar.Z 'patches.tar.gz')
md5sums=('5d607a13dd42e559bfc90e278a8ec919'
- '0d0285e6f81f24a961adf9d9f84973ce')
+ 'e65fffc8956e953f37a767ce9782b592')
prepare() {
cd "$srcdir/hdfeos5"
# patches
- #patch -Np1 --ignore-whitespace -i "$srcdir/patches/pthreads.patch"
- patch -Np1 --ignore-whitespace -i "$srcdir/patches/pkg-config.patch"
- patch -Np1 --ignore-whitespace -i "$srcdir/patches/configure.patch"
- patch -Np1 --ignore-whitespace -i "$srcdir/patches/gctp_remove.patch"
- patch -Np1 --ignore-whitespace -i "$srcdir/patches/libtool_fixes.patch"
- patch -Np1 --ignore-whitespace -i "$srcdir/patches/hdf5_transition.patch"
- patch -Np1 --ignore-whitespace -i "$srcdir/patches/hdf_hl.patch"
- #patch -Np1 --ignore-whitespace -i "$srcdir/patches/strcpy-overlap.patch"
- patch -Np1 --ignore-whitespace -i "$srcdir/patches/fix_HE5_EHHEisHE5.patch"
+ #patch -Np1 --ignore-whitespace -i ../patches/pthreads.patch
+ patch -Np1 --ignore-whitespace -i ../patches/pkg-config.patch
+ patch -Np1 --ignore-whitespace -i ../patches/configure.patch
+ patch -Np1 --ignore-whitespace -i ../patches/gctp_remove.patch
+ patch -Np1 --ignore-whitespace -i ../patches/libtool_fixes.patch
+ patch -Np1 --ignore-whitespace -i ../patches/hdf5_transition.patch
+ patch -Np1 --ignore-whitespace -i ../patches/hdf_hl.patch
+ #patch -Np1 --ignore-whitespace -i ../patches/strcpy-overlap.patch
+ patch -Np1 --ignore-whitespace -i ../patches/fix_HE5_EHHEisHE5.patch
+ patch -Np1 --ignore-whitespace -i ../patches/hdf5_1.10.patch
}
build() {
@@ -35,10 +36,10 @@ build() {
export CFLAGS="-D_HDFEOS5_THREADSAFE ${CFLAGS/O2/O0}"
export CXXFLAGS="${CFLAGS}"
- export CC="/usr/bin/h5cc_18"
+ export CC="/usr/bin/h5cc"
#export CPPFLAGS="-Df2cFortran -I/usr/include"
- ./configure CC=/usr/bin/h5cc_18 --with-hdf5=/usr --with-zlib=/usr --prefix=/usr \
+ ./configure CC=/usr/bin/h5cc --with-hdf5=/usr --with-zlib=/usr --prefix=/usr \
--disable-static \
--enable-static=no \
--enable-hl \
diff --git a/patches.tar.gz b/patches.tar.gz
index fbcdcfe64579..7d04452ddfc0 100644
--- a/patches.tar.gz
+++ b/patches.tar.gz
Binary files differ