summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavierCLL2016-07-18 18:09:16 -0500
committerXavierCLL2016-07-18 18:09:16 -0500
commitabde8b3cd6635874e94ed0e876e9f36d88ae6650 (patch)
tree8227ae10b26bd803496d3709df1505df83e62cfc
parentdc3b33f11f07f56f6d35a404715d591af3a36c92 (diff)
downloadaur-abde8b3cd6635874e94ed0e876e9f36d88ae6650.tar.gz
Updated dependecies and organize the pkgbuild thanks to richli
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD50
2 files changed, 30 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70b59920b913..b534a68b7326 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
+# Generated by mksrcinfo v8
+# Mon Jul 18 23:08:00 UTC 2016
pkgbase = hdf-eos5
pkgdesc = The HDF-EOS5 is a software library designed built on HDF5 to support the same Grid/Point/Swath functionality in HDF-EOS 2 and to the extent possible it will be built with the same calling sequences as the original HDF-EOS 2 library.
pkgver = 1.15
- pkgrel = 3
+ pkgrel = 4
url = http://www.hdfeos.org/software/library.php
arch = i686
arch = x86_64
license = GPL
depends = szip
- depends = hdf5
+ depends = hdf5_18
depends = gdal
depends = hdf-eos-common
options = libtool
diff --git a/PKGBUILD b/PKGBUILD
index 9ca6b5be600b..036a34f9d0c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,44 @@
-# Maintainer: (epsilom) Xavier Corredor <xavier.corredor.llano (a) gmail.com>
+# Maintainer: XavierCLL <xavier.corredor.llano (a) gmail.com>
+# Contributor: richli
pkgname=hdf-eos5
pkgver=1.15
-pkgrel=3
+pkgrel=4
pkgdesc="The HDF-EOS5 is a software library designed built on HDF5 to support the same Grid/Point/Swath functionality in HDF-EOS 2 and to the extent possible it will be built with the same calling sequences as the original HDF-EOS 2 library."
url="http://www.hdfeos.org/software/library.php"
license=('GPL')
arch=('i686' 'x86_64')
-depends=('szip' 'hdf5' 'gdal' 'hdf-eos-common')
+depends=('szip' 'hdf5_18' 'gdal' 'hdf-eos-common')
options=('libtool' 'staticlibs')
source=(ftp://edhs1.gsfc.nasa.gov/edhs/hdfeos5/latest_release/HDF-EOS5.$pkgver.tar.Z 'patches.tar.gz')
md5sums=('5d607a13dd42e559bfc90e278a8ec919'
'0d0285e6f81f24a961adf9d9f84973ce')
+prepare() {
+ cd "$srcdir/hdfeos5"
+ # patches
+ #patch -Np1 --ignore-whitespace -i "$srcdir/patches/pthreads.patch"
+ patch -Np1 --ignore-whitespace -i "$srcdir/patches/pkg-config.patch"
+ patch -Np1 --ignore-whitespace -i "$srcdir/patches/configure.patch"
+ patch -Np1 --ignore-whitespace -i "$srcdir/patches/gctp_remove.patch"
+ patch -Np1 --ignore-whitespace -i "$srcdir/patches/libtool_fixes.patch"
+ patch -Np1 --ignore-whitespace -i "$srcdir/patches/hdf5_transition.patch"
+ patch -Np1 --ignore-whitespace -i "$srcdir/patches/hdf_hl.patch"
+ #patch -Np1 --ignore-whitespace -i "$srcdir/patches/strcpy-overlap.patch"
+ patch -Np1 --ignore-whitespace -i "$srcdir/patches/fix_HE5_EHHEisHE5.patch"
+}
+
build() {
- cd $srcdir/hdfeos5
+ cd "$srcdir/hdfeos5"
#export LDFLAGS="-lhe5_hdfeos -lGctp -lhdf5_hl -lhdf5 -ljpeg -lz -lsz -lm"
export LDFLAGS="-lhdf5_hl -lhdf5 -ljpeg -lz -lsz -lm"
export CFLAGS="-D_HDFEOS5_THREADSAFE ${CFLAGS/O2/O0}"
export CXXFLAGS="${CFLAGS}"
- export CC="/usr/bin/h5cc"
+ export CC="/usr/bin/h5cc_18"
#export CPPFLAGS="-Df2cFortran -I/usr/include"
- # patches
- #patch -Np1 --ignore-whitespace -i $srcdir/patches/pthreads.patch
- patch -Np1 --ignore-whitespace -i $srcdir/patches/pkg-config.patch
- patch -Np1 --ignore-whitespace -i $srcdir/patches/configure.patch
- patch -Np1 --ignore-whitespace -i $srcdir/patches/gctp_remove.patch
- patch -Np1 --ignore-whitespace -i $srcdir/patches/libtool_fixes.patch
- patch -Np1 --ignore-whitespace -i $srcdir/patches/hdf5_transition.patch
- patch -Np1 --ignore-whitespace -i $srcdir/patches/hdf_hl.patch
- #patch -Np1 --ignore-whitespace -i $srcdir/patches/strcpy-overlap.patch
- patch -Np1 --ignore-whitespace -i $srcdir/patches/fix_HE5_EHHEisHE5.patch
-
-
- ./configure CC=/usr/bin/h5cc --with-hdf5=/usr --with-zlib=/usr --prefix=/usr \
+ ./configure CC=/usr/bin/h5cc_18 --with-hdf5=/usr --with-zlib=/usr --prefix=/usr \
--disable-static \
--enable-static=no \
--enable-hl \
@@ -55,14 +58,13 @@ build() {
}
package() {
- cd $srcdir/hdfeos5
- make DESTDIR=$pkgdir install
+ cd "$srcdir/hdfeos5"
+ make DESTDIR="$pkgdir" install
# delete common files
- rm $pkgdir/usr/include/{cfortHdf.h,cproj.h,ease.h,isin.h,proj.h,bcea.h,cproj_prototypes.h,gctp_prototypes.h}
+ rm "$pkgdir"/usr/include/{cfortHdf.h,cproj.h,ease.h,isin.h,proj.h,bcea.h,cproj_prototypes.h,gctp_prototypes.h}
#install example
- install -d -m755 $pkgdir/usr/share/doc/hdf-eos5
- install -m644 samples/* $pkgdir/usr/share/doc/hdf-eos5/
-
+ install -d -m755 "$pkgdir/usr/share/doc/hdf-eos5"
+ install -m644 samples/* "$pkgdir/usr/share/doc/hdf-eos5/"
}