summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavierCLL2018-08-21 10:02:27 -0500
committerXavierCLL2018-08-21 10:02:27 -0500
commitee643789f3ee40d79638deccc7413c679568404b (patch)
tree5c714abfd6100f3681b6b7e2855203ced5d3f67b
parent9e35ed1ff2a85e7416238d3074d0ad1368df8df0 (diff)
downloadaur-ee643789f3ee40d79638deccc7413c679568404b.tar.gz
Fixes
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
-rw-r--r--szip_cc.patch14
3 files changed, 28 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a68d418c675b..4dc9e85815eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,22 @@
pkgbase = hdf-eos5
pkgdesc = The HDF-EOS5 is a software library designed built on HDF5 to support the same Grid/Point/Swath functionality in HDF-EOS 2 and to the extent possible it will be built with the same calling sequences as the original HDF-EOS 2 library.
pkgver = 1.16
- pkgrel = 1
+ pkgrel = 2
url = http://www.hdfeos.org/software/library.php
arch = i686
arch = x86_64
license = GPL
depends = zlib
depends = libaec
- depends = hdf5_18
+ depends = hdf5
depends = gdal
depends = hdf-eos-common
options = libtool
options = staticlibs
source = ftp://edhs1.gsfc.nasa.gov/edhs/hdfeos5/latest_release/HDF-EOS5.1.16.tar.Z
+ source = szip_cc.patch
md5sums = c4a3286f38a2faafc840017af4bd39d6
+ md5sums = f4bf627e4dedaae3f142ca05253743eb
pkgname = hdf-eos5
diff --git a/PKGBUILD b/PKGBUILD
index e6c82799fc45..03343629efb2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,27 @@
pkgname=hdf-eos5
pkgver=1.16
-pkgrel=1
+pkgrel=2
pkgdesc="The HDF-EOS5 is a software library designed built on HDF5 to support the same Grid/Point/Swath functionality in HDF-EOS 2 and to the extent possible it will be built with the same calling sequences as the original HDF-EOS 2 library."
url="http://www.hdfeos.org/software/library.php"
license=('GPL')
arch=('i686' 'x86_64')
-depends=('zlib' 'libaec' 'hdf5_18' 'gdal' 'hdf-eos-common')
+depends=('zlib' 'libaec' 'hdf5' 'gdal' 'hdf-eos-common')
options=('libtool' 'staticlibs')
-source=(ftp://edhs1.gsfc.nasa.gov/edhs/hdfeos5/latest_release/HDF-EOS5.$pkgver.tar.Z)
-md5sums=('c4a3286f38a2faafc840017af4bd39d6')
+source=("ftp://edhs1.gsfc.nasa.gov/edhs/hdfeos5/latest_release/HDF-EOS5.$pkgver.tar.Z"
+ "szip_cc.patch")
+md5sums=('c4a3286f38a2faafc840017af4bd39d6'
+ 'f4bf627e4dedaae3f142ca05253743eb')
build() {
cd "hdfeos5"
- #export LDFLAGS="-lhe5_hdfeos -lGctp -lhdf5_hl -lhdf5 -ljpeg -lz -lsz -lm"
- export LDFLAGS="-lhdf5_hl -lhdf5 -ljpeg -lz -lsz -lm"
-
- export CFLAGS="-D_HDFEOS5_THREADSAFE ${CFLAGS/O2/O0}"
- export CXXFLAGS="${CFLAGS}"
- export CC="/usr/bin/h5cc_18"
- #export CPPFLAGS="-Df2cFortran -I/usr/include"
- ./configure CC=/usr/bin/h5cc_18 --with-hdf5=/usr --with-zlib=/usr --prefix=/usr \
+ patch -p1 -i ../szip_cc.patch
+
+ ./configure CC=/usr/bin/h5cc --with-hdf5=/usr --with-zlib=/usr --prefix=/usr \
--disable-static \
--enable-static=no \
+ --with-szlib=/usr \
--enable-hl \
--enable-threadsafe \
--enable-linux-lfs \
diff --git a/szip_cc.patch b/szip_cc.patch
new file mode 100644
index 000000000000..cbd64ae6aec3
--- /dev/null
+++ b/szip_cc.patch
@@ -0,0 +1,14 @@
+--- a/configure
++++ b/configure
+@@ -22107,11 +22107,7 @@
+ { (exit 1); exit 1; }; }
+ fi
+
+- SZIP_CC=szip_cc
+- cat $PURE_CC | $AWK '{ if ( $0 ~ /^LDFLAGS=\"(.*)/ ) { print substr($0, 1, 9) " -L'$szlib_lib' " substr($0, 10) } else { print } } ' > $SZIP_CC
+- chmod 755 $SZIP_CC
+ saved_CC="$CC"
+- CC=./$SZIP_CC
+
+ { echo "$as_me:$LINENO: checking for szlib encoder" >&5
+ echo $ECHO_N "checking for szlib encoder... $ECHO_C" >&6; }