summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorgios Eleftheriou2018-08-22 03:30:17 +0200
committerGeorgios Eleftheriou2018-08-22 03:30:17 +0200
commitccb634937c65e1fe87673fed6d1b29d7f0ed08cc (patch)
tree499d1f051990da99b8ae786784928b0d6d336758
parent97760e049d418b5e478b678f298ee50042c1ce26 (diff)
downloadaur-ccb634937c65e1fe87673fed6d1b29d7f0ed08cc.tar.gz
merged the java interfaces and introduced libaec dependency
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
2 files changed, 23 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7f7ecee8017..4eadbcc2e168 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,19 @@
pkgbase = hdf4
- pkgdesc = General purpose library and file format for storing scientific data
+ pkgdesc = General purpose library and file format for storing scientific data (full version including the FORTRAN and the Java Native Interfaces - JNI)
pkgver = 4.2.14
- pkgrel = 1
+ pkgrel = 2
url = https://portal.hdfgroup.org/display/support/HDF+4.2.14
arch = x86_64
license = custom
+ makedepends = java-environment
makedepends = gcc-fortran
+ depends = libaec
depends = zlib
depends = libjpeg-turbo
depends = libtirpc
+ provides = hdf4-java
conflicts = hdf4-java
+ replaces = hdf4-java
source = https://support.hdfgroup.org/ftp/HDF/releases/HDF4.2.14/src/hdf-4.2.14.tar.bz2
source = config.patch
md5sums = 3f3bd5da84015e9221d26fb5a80094b4
diff --git a/PKGBUILD b/PKGBUILD
index a2c8f8a141a0..ff76c9303f54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,52 @@
# Maintainer : George Eleftheriou <eleftg>
+# Contributor: Jingbei Li <petronny>
+# Contributor: XavierCLL <xavier dot corredor dot llano at gmail dot com>
# Contributor: David Scholl <djscholl at gmail dot com>
pkgname=hdf4
pkgver=4.2.14
-pkgrel=1
-pkgdesc="General purpose library and file format for storing scientific data"
+pkgrel=2
+pkgdesc="General purpose library and file format for storing scientific data (full version including the FORTRAN and the Java Native Interfaces - JNI)"
arch=('x86_64')
url="https://portal.hdfgroup.org/display/support/HDF+4.2.14"
license=('custom')
-depends=('zlib' 'libjpeg-turbo' 'libtirpc')
-makedepends=('gcc-fortran')
+depends=('libaec' 'zlib' 'libjpeg-turbo' 'libtirpc')
+makedepends=('java-environment' 'gcc-fortran')
conflicts=('hdf4-java')
+provides=('hdf4-java')
+replaces=('hdf4-java')
source=("https://support.hdfgroup.org/ftp/HDF/releases/HDF${pkgver}/src/hdf-${pkgver}.tar.bz2"
"config.patch")
md5sums=('3f3bd5da84015e9221d26fb5a80094b4'
'e17d14ac1d27012c1ea9ac03f783d355')
prepare() {
- cd "${srcdir}/hdf-${pkgver}"
+ [ ! -d build ] && mkdir -p build
+ cd "hdf-${pkgver}"
patch < "${srcdir}/config.patch"
autoreconf -i
}
build() {
- cd "${srcdir}/hdf-${pkgver}"
+ cd build
- ./configure \
+ "${srcdir}/hdf-${pkgver}"/configure \
CFLAGS="${CFLAGS} -fPIC" \
- LDFLAGS="-l:libjpeg.so.8 ${LDFLAGS}" \
+ LIBS="-ljpeg -laec -lsz" \
F77=gfortran \
+ JAVADOC='javadoc -Xdoclint:none' \
--enable-fortran \
+ --enable-java \
--enable-production \
--with-zlib \
+ --with-szlib=/usr \
--prefix=/opt/hdf4
make
}
package() {
- cd "${srcdir}/hdf-${pkgver}"
+ cd build
make -j1 DESTDIR="${pkgdir}" install
mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
cp "${srcdir}/hdf-${pkgver}/COPYING" "${pkgdir}/usr/share/licenses/${pkgname}"