summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorgios Eleftheriou2019-01-26 22:34:09 +0100
committerGeorgios Eleftheriou2019-01-26 22:34:09 +0100
commitbb70472465171a4a6bc4f8cb92e54f7cdb27610e (patch)
treeccc2507d93995f5f409e15e9cb0b85d2851191a2
downloadaur-bb70472465171a4a6bc4f8cb92e54f7cdb27610e.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD54
-rw-r--r--config.patch14
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0b6c8df3fa8f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = hdf4-static
+ pkgdesc = General purpose library and file format for storing scientific data (version including the FORTRAN interfaces)
+ pkgver = 4.2.14
+ pkgrel = 1
+ url = https://portal.hdfgroup.org/display/support/HDF+4.2.14
+ arch = x86_64
+ license = custom
+ makedepends = gcc-fortran
+ depends = libaec
+ depends = zlib
+ depends = libjpeg-turbo
+ depends = libtirpc
+ options = staticlibs
+ source = https://support.hdfgroup.org/ftp/HDF/releases/HDF4.2.14/src/hdf-4.2.14.tar.bz2
+ source = config.patch
+ md5sums = 3f3bd5da84015e9221d26fb5a80094b4
+ md5sums = e17d14ac1d27012c1ea9ac03f783d355
+
+pkgname = hdf4-static
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3684ca0de581
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer : George Eleftheriou <eleftg>
+# Maintainer : XavierCLL <xavier dot corredor dot llano at gmail dot com>
+# Contributor: Jingbei Li <petronny>
+# Contributor: David Scholl <djscholl at gmail dot com>
+
+pkgname=hdf4-static
+_pkgname=hdf4
+pkgver=4.2.14
+pkgrel=1
+pkgdesc="General purpose library and file format for storing scientific data (version including the FORTRAN interfaces)"
+arch=('x86_64')
+url="https://portal.hdfgroup.org/display/support/HDF+4.2.14"
+license=('custom')
+options=('staticlibs')
+depends=('libaec' 'zlib' 'libjpeg-turbo' 'libtirpc')
+makedepends=('gcc-fortran')
+source=("https://support.hdfgroup.org/ftp/HDF/releases/HDF${pkgver}/src/hdf-${pkgver}.tar.bz2"
+ "config.patch")
+md5sums=('3f3bd5da84015e9221d26fb5a80094b4'
+ 'e17d14ac1d27012c1ea9ac03f783d355')
+
+prepare() {
+ mkdir -p build
+ cd "hdf-${pkgver}"
+ patch < "${srcdir}/config.patch"
+ autoreconf -i
+}
+
+build() {
+ cd build
+
+ "${srcdir}/hdf-${pkgver}"/configure \
+ CFLAGS="${CFLAGS} -fPIC" \
+ FFLAGS="${FFLAGS} -fPIC -ffixed-line-length-none" \
+ LIBS="-ljpeg -laec -lsz" \
+ F77=gfortran \
+ --enable-static \
+ --disable-shared \
+ --enable-fortran \
+ --disable-netcdf \
+ --enable-production \
+ --with-zlib \
+ --with-szlib=/usr \
+ --prefix=/opt/"${pkgname}"
+
+ make
+}
+
+package() {
+ cd build
+ make -j1 DESTDIR="${pkgdir}" install
+ install -dm 755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm 644 "${srcdir}/hdf-${pkgver}/COPYING" "${pkgdir}/usr/share/licenses/${pkgname}"
+}
diff --git a/config.patch b/config.patch
new file mode 100644
index 000000000000..39531ce170e4
--- /dev/null
+++ b/config.patch
@@ -0,0 +1,14 @@
+diff --git a/src/hdf-4.2.14/configure.ac b/src/hdf-4.2.14/configure.ac
+index 3030bad..6d7f654 100644
+--- a/src/hdf-4.2.14/configure.ac
++++ b/src/hdf-4.2.14/configure.ac
+@@ -685,6 +685,9 @@ case "$host" in
+ *-pc-cygwin*)
+ LIBS="$LIBS -ltirpc"
+ CPPFLAGS="$CPPFLAGS -I/usr/include/tirpc" ;;
++ *-linux-gnu*)
++ LIBS="$LIBS -ltirpc"
++ CPPFLAGS="$CPPFLAGS -I/usr/include/tirpc" ;;
+ *) ;;
+ esac
+