summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Eleftheriou2017-10-20 00:30:15 +0200
committerGeorge Eleftheriou2017-10-20 00:30:15 +0200
commitd6bc002b5a4d7a6ed372f791c0c42599cb232a55 (patch)
tree059e599945aa8ef20879e597bebd653ea1faaa42
downloadaur-d6bc002b5a4d7a6ed372f791c0c42599cb232a55.tar.gz
initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD74
-rw-r--r--mpi.patch18
3 files changed, 119 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee9beb00b975
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = hdf5-openmpi-java
+ pkgdesc = General purpose library and file format for storing scientific data (openmpi version) (full version including its Java Native Interfaces)
+ pkgver = 1.10.1
+ pkgrel = 1
+ url = https://www.hdfgroup.org/HDF5/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = time
+ makedepends = gcc-fortran
+ makedepends = java-environment
+ depends = zlib
+ depends = openmpi
+ provides = hdf5-openmpi
+ provides = hdf5
+ provides = hdf5-cpp-fortran
+ provides = hdf5-fortran-openmpi
+ conflicts = hdf5
+ conflicts = hdf5-openmpi
+ replaces = hdf5-fortran-openmpi
+ source = https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-1.10/hdf5-1.10.1/src/hdf5-1.10.1.tar.bz2
+ source = mpi.patch
+ md5sums = d89893c05ee7ea8611b51bb39450d64e
+ md5sums = dfa8dd50b8a7ebb3ad7249c627156cf9
+
+pkgname = hdf5-openmpi-java
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3fea1ab60c8f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,74 @@
+# $Id$
+# Maintainer : George Eleftheriou <eleftg>
+# Contributor: Ronald van Haren <ronald.archlinux.org>
+# Contributor: Bruno Pagani (a.k.a. ArchangeGabriel) <archange@archlinux.org>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: damir <damir@archlinux.org>
+# Contributor: Tom K <tomk@runbox.com>
+# Contributor: Jed Brown <jed@59A2.org>
+# Contributor: Simone Pezzuto <junki.gnu@gmail.com>
+
+_pkgname=hdf5
+_mpi=openmpi
+pkgname=${_pkgname}-${_mpi}-java
+pkgver=1.10.1
+pkgrel=1
+pkgdesc="General purpose library and file format for storing scientific data (${_mpi} version) (full version including its Java Native Interfaces)"
+arch=('i686' 'x86_64')
+url="https://www.hdfgroup.org/HDF5/"
+license=('custom')
+depends=('zlib' 'openmpi')
+makedepends=('time' 'gcc-fortran' 'java-environment')
+provides=('hdf5-openmpi' 'hdf5' 'hdf5-cpp-fortran' "hdf5-fortran-${_mpi}")
+conflicts=('hdf5' 'hdf5-openmpi')
+replaces=("hdf5-fortran-${_mpi}")
+source=("https://support.hdfgroup.org/ftp/HDF5/releases/${_pkgname}-${pkgver:0:4}/${_pkgname}-${pkgver/_/-}/src/${_pkgname}-${pkgver/_/-}.tar.bz2"
+ 'mpi.patch')
+md5sums=('d89893c05ee7ea8611b51bb39450d64e'
+ 'dfa8dd50b8a7ebb3ad7249c627156cf9')
+
+prepare() {
+ cd ${_pkgname}-${pkgver/_/-}
+
+ # FS#33343
+ patch -p1 -i ../mpi.patch
+}
+
+build() {
+ cd ${_pkgname}-${pkgver/_/-}
+ ./configure \
+ CXX="mpicxx" \
+ CC="mpicc" \
+ FC="mpif90" \
+ F9X="mpif90" \
+ RUNPARALLEL="mpirun" \
+ OMPI_MCA_disable_memory_allocator=1 \
+ --prefix=/usr \
+ --disable-static \
+ --enable-hl \
+ --enable-build-mode=production \
+ --with-pic \
+ --docdir=/usr/share/doc/hdf5/ \
+ --disable-sharedlib-rpath \
+ --enable-cxx \
+ --enable-fortran \
+ --enable-fortran2003 \
+ --enable-java \
+ --enable-parallel \
+ --enable-unsupported \
+ --with-zlib
+ make
+}
+
+package() {
+ cd ${_pkgname}-${pkgver/_/-}
+
+ make -j1 DESTDIR="${pkgdir}" install
+
+ rm -rf "${pkgdir}"/usr/lib/libdynlib*.so
+
+ install -dm755 "${pkgdir}"/usr/share/${_pkgname}
+ mv "${pkgdir}"/usr/share/{hdf5_examples,${_pkgname}/examples}
+
+ install -Dm644 COPYING "${pkgdir}"/usr/share/licenses/${_pkgname}/LICENSE
+}
diff --git a/mpi.patch b/mpi.patch
new file mode 100644
index 000000000000..4fadc13e26ab
--- /dev/null
+++ b/mpi.patch
@@ -0,0 +1,18 @@
+Prevent accidental inclusion of mpi c++ headers
+when hdf5.h is included third party library
+
+https://bugs.gentoo.org/show_bug.cgi?id=420777
+https://bugs.archlinux.org/task/33343
+
+--- a/src/H5public.h
++++ b/src/H5public.h
+@@ -58,6 +58,8 @@
+ # include <stddef.h>
+ #endif
+ #ifdef H5_HAVE_PARALLEL
++# define OMPI_SKIP_MPICXX /* Make sure that cxx specific headers are not included */
++# define MPICH_SKIP_MPICXX
+ # include <mpi.h>
+ #ifndef MPI_FILE_NULL /*MPIO may be defined in mpi.h already */
+ # include <mpio.h>
+