summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Eleftheriou2017-10-15 11:56:02 +0200
committerGeorge Eleftheriou2017-10-15 11:56:02 +0200
commit68aa56faf83f46d7cdea145e90a21baa669d731c (patch)
tree266b27fe7a86d90421edab517c0f3c9af7d0636f
downloadaur-68aa56faf83f46d7cdea145e90a21baa669d731c.tar.gz
initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD56
-rw-r--r--mpi.patch17
3 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c3c68c834a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = hdf5_18-mpich
+ pkgdesc = The hdf5 legacy 1.8 series compiled with mpich support
+ pkgver = 1.8.19
+ pkgrel = 1
+ url = https://support.hdfgroup.org/HDF5/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = gcc-fortran
+ depends = zlib
+ depends = mpich
+ provides = hdf5_18
+ provides = hdf5_18-cpp-fortran
+ provides = hdf5-fortran-mpich
+ conflicts = hdf5_18
+ conflicts = hdf5_18-cpp-fortran
+ conflicts = hdf5-fortran-mpich
+ replaces = hdf5-fortran-mpich
+ source = https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-1.8/hdf5-1.8.19/src/hdf5-1.8.19.tar.bz2
+ source = mpi.patch
+ md5sums = 6f0353ee33e99089c110a1c8d2dd1b22
+ md5sums = b7165950c96ba4a2540984d07886accf
+
+pkgname = hdf5_18-mpich
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6dfa0aeb5aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: George Eleftheriou
+
+pkgname=hdf5_18-mpich
+_pkgname=hdf5
+pkgver=1.8.19
+pkgrel=1
+pkgdesc="The hdf5 legacy 1.8 series compiled with mpich support"
+arch=('i686' 'x86_64')
+url="https://support.hdfgroup.org/HDF5/"
+license=('custom')
+depends=('zlib' 'mpich')
+makedepends=('gcc-fortran')
+provides=('hdf5_18' 'hdf5_18-cpp-fortran' 'hdf5-fortran-mpich')
+conflicts=('hdf5_18' 'hdf5_18-cpp-fortran' 'hdf5-fortran-mpich')
+replaces=('hdf5-fortran-mpich')
+source=("https://support.hdfgroup.org/ftp/HDF5/releases/${_pkgname}-${pkgver:0:3}/${_pkgname}-${pkgver}/src/${_pkgname}-${pkgver}.tar.bz2"
+ "mpi.patch")
+md5sums=('6f0353ee33e99089c110a1c8d2dd1b22'
+ 'b7165950c96ba4a2540984d07886accf')
+
+prepare() {
+ cd "${_pkgname}-${pkgver}"
+
+ # FS#33343
+ patch -p1 < ${srcdir}/mpi.patch
+}
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ ./configure \
+ CXX="/opt/mpich/bin/mpicxx" \
+ CC="/opt/mpich/bin/mpicc" \
+ FC="/opt/mpich/bin/mpif90" \
+ F9X="/opt/mpich/bin/mpif90" \
+ RUNPARALLEL="/opt/mpich/bin/mpirun" \
+ --prefix=/opt/${_pkgname}-${pkgver}-mpich \
+ --enable-production \
+ --enable-parallel \
+ --enable-unsupported \
+ --enable-using-memchecker --enable-clear-file-buffers \
+ --enable-hl \
+ --enable-cxx \
+ --enable-fortran \
+ --enable-fortran2003 \
+ --with-pic \
+ --disable-static \
+ --disable-sharedlib-rpath \
+ --with-zlib
+
+ make
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ make -j1 DESTDIR="${pkgdir}" install
+}
diff --git a/mpi.patch b/mpi.patch
new file mode 100644
index 000000000000..15f142b92cfc
--- /dev/null
+++ b/mpi.patch
@@ -0,0 +1,17 @@
+Prevent accidental inclusion of mpi c++ headers
+when hdf5.h is included third party library
+
+https://bugs.gentoo.org/show_bug.cgi?id=420777
+https://bugs.archlinux.org/task/33343
+
+--- a/src/H5public.h
++++ b/src/H5public.h
+@@ -56,6 +56,8 @@
+ # include <stddef.h>
+ #endif
+ #ifdef H5_HAVE_PARALLEL
++# define OMPI_SKIP_MPICXX /* Make sure that cxx specific headers are not included */
++# define MPICH_SKIP_MPICXX
+ # include <mpi.h>
+ #ifndef MPI_FILE_NULL /*MPIO may be defined in mpi.h already */
+ # include <mpio.h>