summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorgios Eleftheriou2018-07-28 15:49:37 +0200
committerGeorgios Eleftheriou2018-07-28 15:49:37 +0200
commit6be1e75978a37f07cb1f5cc0406b2025d2618f6f (patch)
treebfcbbf445e76e0895f818a86653cde10b22c787d
parentb3765d1a1423f09790ed9538b1acc94f35f30ceb (diff)
downloadaur-6be1e75978a37f07cb1f5cc0406b2025d2618f6f.tar.gz
PKGBUILD cleanup and tests
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2349b95a67b..e17606f2642d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hdf5_18-mpich
pkgdesc = The hdf5 legacy 1.8 series compiled with mpich support
pkgver = 1.8.21
- pkgrel = 1
+ pkgrel = 2
url = https://support.hdfgroup.org/HDF5/
arch = x86_64
license = custom
diff --git a/PKGBUILD b/PKGBUILD
index 5c980284d3c4..e8e68e20ee62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _mpi=mpich
pkgname=${_legacypkg}-${_mpi}
_pkgname=${_legacypkg:0:4}
pkgver=1.8.21
-pkgrel=1
+pkgrel=2
pkgdesc="The hdf5 legacy 1.8 series compiled with ${_mpi} support"
arch=('x86_64')
url="https://support.hdfgroup.org/HDF5/"
@@ -28,6 +28,7 @@ prepare() {
build() {
cd "${_pkgname}-${pkgver}"
+
./configure \
CXX="/opt/mpich/bin/mpicxx" \
CC="/opt/mpich/bin/mpicc" \
@@ -51,7 +52,16 @@ build() {
make
}
+check() {
+ cd "${_pkgname}-${pkgver}"
+
+ # This is a parallel build, there will always be some MPI bugs,
+ # so skip failures and don't kill the entire packaging process
+ make check || warning "Some tests failed"
+}
+
package() {
cd "${_pkgname}-${pkgver}"
+
make -j1 DESTDIR="${pkgdir}" install
}