summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Eleftheriou2018-06-11 01:51:26 +0200
committerGeorge Eleftheriou2018-06-11 01:51:26 +0200
commitb3765d1a1423f09790ed9538b1acc94f35f30ceb (patch)
treee48f4c22cdd07ce54866f29390b0c6cc079ce667
parent4d1aa6f981091cb3d2fca8d79bd3e29c122ffc2f (diff)
downloadaur-b3765d1a1423f09790ed9538b1acc94f35f30ceb.tar.gz
upgpkg: upgraded to 1.8.21
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD73
2 files changed, 41 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fbb956518629..c2349b95a67b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,21 @@
pkgbase = hdf5_18-mpich
pkgdesc = The hdf5 legacy 1.8 series compiled with mpich support
- pkgver = 1.8.20
+ pkgver = 1.8.21
pkgrel = 1
url = https://support.hdfgroup.org/HDF5/
- arch = i686
arch = x86_64
license = custom
makedepends = gcc-fortran
depends = zlib
+ depends = libaec
depends = mpich
provides = hdf5_18
provides = hdf5_18-cpp-fortran
- provides = hdf5-fortran-mpich
conflicts = hdf5_18
conflicts = hdf5_18-cpp-fortran
- conflicts = hdf5-fortran-mpich
- replaces = hdf5-fortran-mpich
- source = https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-1.8/hdf5-1.8.20/src/hdf5-1.8.20.tar.bz2
+ source = https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-1.8/hdf5-1.8.21/src/hdf5-1.8.21.tar.bz2
source = mpi.patch
- md5sums = 23078d57975903e9536d1e7b299cc39c
+ md5sums = 2d2408f2a9dfb5c7b79998002e9a90e9
md5sums = c261676f9ee4b5a2f3bca9f5d4ba89aa
pkgname = hdf5_18-mpich
diff --git a/PKGBUILD b/PKGBUILD
index a10fefd6b0e6..5c980284d3c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,56 +1,57 @@
# Maintainer: George Eleftheriou
-pkgname=hdf5_18-mpich
-_pkgname=hdf5
-pkgver=1.8.20
+_legacypkg=hdf5_18
+_mpi=mpich
+pkgname=${_legacypkg}-${_mpi}
+_pkgname=${_legacypkg:0:4}
+pkgver=1.8.21
pkgrel=1
-pkgdesc="The hdf5 legacy 1.8 series compiled with mpich support"
-arch=('i686' 'x86_64')
+pkgdesc="The hdf5 legacy 1.8 series compiled with ${_mpi} support"
+arch=('x86_64')
url="https://support.hdfgroup.org/HDF5/"
license=('custom')
-depends=('zlib' 'mpich')
+depends=('zlib' 'libaec' "${_mpi}")
makedepends=('gcc-fortran')
-provides=('hdf5_18' 'hdf5_18-cpp-fortran' 'hdf5-fortran-mpich')
-conflicts=('hdf5_18' 'hdf5_18-cpp-fortran' 'hdf5-fortran-mpich')
-replaces=('hdf5-fortran-mpich')
+provides=('hdf5_18' 'hdf5_18-cpp-fortran')
+conflicts=('hdf5_18' 'hdf5_18-cpp-fortran')
source=("https://support.hdfgroup.org/ftp/HDF5/releases/${_pkgname}-${pkgver:0:3}/${_pkgname}-${pkgver}/src/${_pkgname}-${pkgver}.tar.bz2"
"mpi.patch")
-md5sums=('23078d57975903e9536d1e7b299cc39c'
+md5sums=('2d2408f2a9dfb5c7b79998002e9a90e9'
'c261676f9ee4b5a2f3bca9f5d4ba89aa')
prepare() {
- cd "${_pkgname}-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
- # FS#33343
- patch -p1 < ${srcdir}/mpi.patch
+ # FS#33343
+ patch -p1 < ${srcdir}/mpi.patch
}
build() {
- cd "${_pkgname}-${pkgver}"
- ./configure \
- CXX="/opt/mpich/bin/mpicxx" \
- CC="/opt/mpich/bin/mpicc" \
- FC="/opt/mpich/bin/mpif90" \
- F9X="/opt/mpich/bin/mpif90" \
- RUNPARALLEL="/opt/mpich/bin/mpirun" \
- --prefix=/opt/${_pkgname}-${pkgver}-mpich \
- --enable-production \
- --enable-parallel \
- --enable-unsupported \
- --enable-using-memchecker --enable-clear-file-buffers \
- --enable-hl \
- --enable-cxx \
- --enable-fortran \
- --enable-fortran2003 \
- --with-pic \
- --disable-static \
- --disable-sharedlib-rpath \
- --with-zlib
+ cd "${_pkgname}-${pkgver}"
+ ./configure \
+ CXX="/opt/mpich/bin/mpicxx" \
+ CC="/opt/mpich/bin/mpicc" \
+ FC="/opt/mpich/bin/mpif90" \
+ F9X="/opt/mpich/bin/mpif90" \
+ RUNPARALLEL="/opt/mpich/bin/mpirun" \
+ --prefix=/opt/${_pkgname}-${pkgver}-${_mpi} \
+ --disable-static \
+ --disable-sharedlib-rpath \
+ --enable-production \
+ --enable-parallel \
+ --enable-unsupported \
+ --enable-hl \
+ --enable-cxx \
+ --enable-fortran \
+ --enable-fortran2003 \
+ --with-pic \
+ --with-zlib \
+ --with-szlib
- make
+ make
}
package() {
- cd "${_pkgname}-${pkgver}"
- make -j1 DESTDIR="${pkgdir}" install
+ cd "${_pkgname}-${pkgver}"
+ make -j1 DESTDIR="${pkgdir}" install
}