summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Eleftheriou2017-10-20 01:02:27 +0200
committerGeorge Eleftheriou2017-10-20 01:02:27 +0200
commit6d6b77af7d6ba7d0e137dca8356959df9c6c3d34 (patch)
tree99765ca4711ad159f08a29b1486ef52b93900a18
downloadaur-6d6b77af7d6ba7d0e137dca8356959df9c6c3d34.tar.gz
initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--HDFView-beta.desktop9
-rw-r--r--HDFView-beta.icobin0 -> 2238 bytes
-rw-r--r--PKGBUILD58
-rw-r--r--license89
5 files changed, 180 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af40f9270eb3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = hdfview-beta
+ pkgdesc = a GUI browser for reading hdf5 files (created with versions up to 1.10)
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = https://support.hdfgroup.org/products/java/release/hdfview3.html
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = apache-ant
+ makedepends = java-environment
+ depends = hdf5-openmpi-java
+ depends = hdf4-java
+ options = !strip
+ source = https://support.hdfgroup.org/ftp/HDF5/releases/HDF-JAVA/hdfview-3.0.0/src/hdfview-3.0.0.tar.gz
+ source = license
+ source = HDFView-beta.desktop
+ source = HDFView-beta.ico
+ md5sums = 0a05625e78c01f4603d03b1fbf0a84cd
+ md5sums = db0de6079dd881781768d05de29c50e0
+ md5sums = 0d10b620f2debd0d73be53873d4bf347
+ md5sums = b86542f80203ea9f93f447fa7c20d25a
+
+pkgname = hdfview-beta
+
diff --git a/HDFView-beta.desktop b/HDFView-beta.desktop
new file mode 100644
index 000000000000..ee6b90dee4b0
--- /dev/null
+++ b/HDFView-beta.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=HDFView-beta
+Comment=HDFView is a GUI tool for browsing and editing HDF4 and HDF5 files.
+Exec=/usr/bin/hdfview-beta.sh
+Icon=/usr/share/pixmaps/HDFView-beta.ico
+Terminal=false
+Type=Application
+Categories=GNOME;GTK;Utility;
+StartupNotify=false
diff --git a/HDFView-beta.ico b/HDFView-beta.ico
new file mode 100644
index 000000000000..b691e2e7a671
--- /dev/null
+++ b/HDFView-beta.ico
Binary files differ
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abe63fb1d59a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer : George Eleftheriou <eleftg>
+# Contributor : Martin Wimpress <code@flexion.org>
+# Contributor : Nick Pope
+# Contributor : Bryce Nordgren <bnordgren at gmail dot com>
+
+pkgname=hdfview-beta
+_pkgname=HDFView
+__pkgname=${pkgname%-beta}
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="a GUI browser for reading hdf5 files (created with versions up to 1.10)"
+arch=('i686' 'x86_64')
+url="https://support.hdfgroup.org/products/java/release/hdfview3.html"
+license=('custom')
+depends=('hdf5-openmpi-java' 'hdf4-java')
+makedepends=('apache-ant' 'java-environment')
+options=(!strip)
+source=("https://support.hdfgroup.org/ftp/HDF5/releases/HDF-JAVA/${__pkgname}-${pkgver}/src/${__pkgname}-${pkgver}.tar.gz"
+ license
+ ${_pkgname}-beta.desktop
+ ${_pkgname}-beta.ico)
+md5sums=('0a05625e78c01f4603d03b1fbf0a84cd'
+ 'db0de6079dd881781768d05de29c50e0'
+ '0d10b620f2debd0d73be53873d4bf347'
+ 'b86542f80203ea9f93f447fa7c20d25a')
+
+prepare() {
+ cd "${__pkgname}-${pkgver}"
+}
+
+build() {
+ cd "${__pkgname}-${pkgver}"
+ HDFLIBS=/usr HDF5LIBS=/usr ant package
+}
+
+package() {
+ cd "${__pkgname}-${pkgver}"
+ mkdir "${pkgdir}/opt"
+ cp -a "build/dist/${_pkgname}-${pkgver}-Linux.sh" "${pkgdir}/opt"
+ cd "${pkgdir}/opt"
+
+ # Make extraction non interactive
+ sed -i 's/interactive=TRUE/interactive=FALSE/' ${_pkgname}-${pkgver}-Linux.sh
+ sed -i 's/cpack_skip_license=FALSE/cpack_skip_license=TRUE/' ${_pkgname}-${pkgver}-Linux.sh
+
+ ./${_pkgname}-${pkgver}-Linux.sh
+ rm "${_pkgname}-${pkgver}-Linux.sh"
+ mkdir -p "${pkgdir}/usr/bin"
+
+ sed -i "s:JAVABIN=${pkgdir}/opt/${_pkgname}/${pkgver}/jre/bin:JAVABIN=/opt/${_pkgname}/${pkgver}/jre/bin:" "${_pkgname}/${pkgver}/hdfview.sh"
+ sed -i "s:INSTALLDIR=${pkgdir}/opt/${_pkgname}/${pkgver}:INSTALLDIR=/opt/${_pkgname}/${pkgver}:" "${_pkgname}/${pkgver}/hdfview.sh"
+
+ # Desktop files, icons, wrappers and license
+ install -D -m 755 "${_pkgname}/${pkgver}/hdfview.sh" "${pkgdir}/usr/bin/hdfview-beta.sh"
+ install -D -m 644 "${srcdir}/${_pkgname}-beta.desktop" "${pkgdir}/usr/share/applications/${_pkgname}-beta.desktop"
+ install -D -m 644 "${srcdir}/${_pkgname}-beta.ico" "${pkgdir}/usr/share/pixmaps/${_pkgname}-beta.ico"
+ install -D -m 644 "${srcdir}/license" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/license b/license
new file mode 100644
index 000000000000..056c8f762de9
--- /dev/null
+++ b/license
@@ -0,0 +1,89 @@
+Copyright Notice and License Terms for
+HDF Java Products
+-----------------------------------------------------------------------------
+
+HDF Java Products
+Copyright 2006-2011 by The HDF Group.
+
+NCSA HDF Java Products
+Copyright 1988-2006 by the Board of Trustees of the University of Illinois.
+
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted for any purpose (including commercial purposes)
+provided that the following conditions are met:
+
+1. Redistributions of source code must retain the above copyright notice,
+ this list of conditions, and the following disclaimer.
+
+2. Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions, and the following disclaimer in the documentation
+ and/or materials provided with the distribution.
+
+3. In addition, redistributions of modified forms of the source or binary
+ code must carry prominent notices stating that the original code was
+ changed and the date of the change.
+
+4. All publications or advertising materials mentioning features or use of
+ this software are asked, but not required, to acknowledge that it was
+ developed by The HDF Group and by the National Center for Supercomputing
+ Applications at the University of Illinois at Urbana-Champaign and
+ credit the contributors.
+
+5. Neither the name of The HDF Group, the name of the University, nor the
+ name of any Contributor may be used to endorse or promote products derived
+ from this software without specific prior written permission from The HDF
+ Group, the University, or the Contributor, respectively.
+
+DISCLAIMER:
+THIS SOFTWARE IS PROVIDED BY THE HDF GROUP AND THE CONTRIBUTORS "AS IS"
+WITH NO WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED. In no event
+shall The HDF Group or the Contributors be liable for any damages suffered
+by the users arising out of the use of this software, even if advised of
+the possibility of such damage.
+
+--------------------------------------------------------------------------
+--------------------------------------------------------------------------
+
+Contributors: National Center for Supercomputing Applications (NCSA) at
+the University of Illinois, Lawrence Livermore National Laboratory (LLNL),
+Sandia National Laboratories (SNL), Los Alamos National Laboratory (LANL),
+Fortner Software, Unidata Program Center (netCDF), The Independent JPEG
+Group (JPEG), Jean-loup Gailly and Mark Adler (gzip), and Digital Equipment
+Corporation (DEC).
+
+--------------------------------------------------------------------------
+
+Portions of the HDF Java Products were developed with support from the
+University of California, Lawrence Livermore National Laboratory (UC LLNL).
+The following statement applies to those portions of the product
+and must be retained in any redistribution of source code, binaries,
+documentation, and/or accompanying materials:
+
+ This work was partially produced at the University of California,
+ Lawrence Livermore National Laboratory (UC LLNL) under contract no.
+ W-7405-ENG-48 (Contract 48) between the U.S. Department of Energy
+ (DOE) and The Regents of the University of California (University)
+ for the operation of UC LLNL.
+
+ DISCLAIMER:
+ This work was prepared as an account of work sponsored by an agency
+ of the United States Government. Neither the United States
+ Government nor the University of California nor any of their
+ employees, makes any warranty, express or implied, or assumes any
+ liability or responsibility for the accuracy, completeness, or
+ usefulness of any information, apparatus, product, or process
+ disclosed, or represents that its use would not infringe privately-
+ owned rights. Reference herein to any specific commercial products,
+ process, or service by trade name, trademark, manufacturer, or
+ otherwise, does not necessarily constitute or imply its endorsement,
+ recommendation, or favoring by the United States Government or the
+ University of California. The views and opinions of authors
+ expressed herein do not necessarily state or reflect those of the
+ United States Government or the University of California, and shall
+ not be used for advertising or product endorsement purposes.
+
+--------------------------------------------------------------------------
+
+