summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-01-30 18:25:22 +0000
committerGrey Christoforo2019-01-30 18:25:22 +0000
commit1d2c4d2513c5a9f2c4cefcbb62de2c0678445bc0 (patch)
treeb5cc25181331d3f0151667c5408527103980791b
downloadaur-1d2c4d2513c5a9f2c4cefcbb62de2c0678445bc0.tar.gz
initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore5
-rw-r--r--HDFView.desktop9
-rw-r--r--HDFView.icobin0 -> 2238 bytes
-rw-r--r--PKGBUILD69
-rw-r--r--license89
6 files changed, 199 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6219c694363
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = hdfview-git
+ pkgdesc = a GUI browser for reading hdf5 files from dev git repo
+ pkgver = r346.d6a3bf6
+ pkgrel = 1
+ url = https://www.hdfgroup.org/downloads/hdfview/
+ arch = x86_64
+ license = custom
+ makedepends = ant
+ makedepends = java-environment
+ depends = hdf5-openmpi-java
+ depends = hdf4
+ provides = hdfview
+ conflicts = hdfview-beta
+ conflicts = hdfview
+ replaces = hdfview-beta
+ options = !strip
+ source = git+https://bitbucket.hdfgroup.org/scm/hdfview/hdfview.git
+ source = license
+ source = HDFView.desktop
+ source = HDFView.ico
+ sha512sums = SKIP
+ sha512sums = d831e3211c67480728488e1e2df2596d41381c5ba7b8451ea0f5174d9a34f224133d9cbaa81728cb68560328054663e8940de86db4777de8b46b65f080de9674
+ sha512sums = 42cbf32c91c4bfd3984d2ef130d8357c28269660117ad210039d9599904688853674f6626a7663c17cf0927895e5cbbede719b6766ff19ace43a5447421a4709
+ sha512sums = bc2bb9ffa22140c1b6b5448ed310a8dbb839ddcf802ec327f32f904f0e77e0034bb26fabeb5d9e4e8ce8d334333327a2bd08b8e07f0313e85ef50afe0be41cfe
+
+pkgname = hdfview-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dc92b3d4ac5c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/src
+/pkg
+/hdfview
+*.tar.gz
+*.tar.xz
diff --git a/HDFView.desktop b/HDFView.desktop
new file mode 100644
index 000000000000..51ba9ab4412d
--- /dev/null
+++ b/HDFView.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=HDFView
+Comment=HDFView is a GUI tool for browsing and editing HDF4 and HDF5 files.
+Exec=/usr/bin/hdfview.sh %F
+Icon=/usr/share/pixmaps/HDFView.ico
+Terminal=false
+Type=Application
+Categories=GNOME;GTK;Utility;
+StartupNotify=false
diff --git a/HDFView.ico b/HDFView.ico
new file mode 100644
index 000000000000..b691e2e7a671
--- /dev/null
+++ b/HDFView.ico
Binary files differ
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b5ad79a7123
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,69 @@
+# Maintainer : Grey Christoforo <first name at last name dot net>
+
+pkgname=hdfview-git
+_pkgname=HDFView
+pkgver=r346.d6a3bf6
+_pkgver="99.99.99"
+pkgrel=1
+pkgdesc="a GUI browser for reading hdf5 files from dev git repo"
+arch=('x86_64')
+url="https://www.hdfgroup.org/downloads/hdfview/"
+license=('custom')
+depends=('hdf5-openmpi-java' 'hdf4')
+replaces=('hdfview-beta')
+conflicts=('hdfview-beta' 'hdfview')
+provides=('hdfview')
+makedepends=('ant' 'java-environment')
+options=(!strip)
+source=("git+https://bitbucket.hdfgroup.org/scm/hdfview/hdfview.git"
+ license
+ ${_pkgname}.desktop
+ ${_pkgname}.ico)
+sha512sums=(
+ 'SKIP'
+ 'd831e3211c67480728488e1e2df2596d41381c5ba7b8451ea0f5174d9a34f224133d9cbaa81728cb68560328054663e8940de86db4777de8b46b65f080de9674'
+ '42cbf32c91c4bfd3984d2ef130d8357c28269660117ad210039d9599904688853674f6626a7663c17cf0927895e5cbbede719b6766ff19ace43a5447421a4709'
+ 'bc2bb9ffa22140c1b6b5448ed310a8dbb839ddcf802ec327f32f904f0e77e0034bb26fabeb5d9e4e8ce8d334333327a2bd08b8e07f0313e85ef50afe0be41cfe')
+
+pkgver() {
+ cd hdfview
+ printf "r%s.%s" "$(git rev-list HEAD --count --first-parent)" "$(git rev-parse --short HEAD)"
+}
+
+
+prepare() {
+ cd hdfview
+}
+
+build() {
+ # workaround for java exception thrown @ build.xml:838
+ # [...] error=7 chmod [...] argument list too long
+ # when building with java 10
+ ulimit -s unlimited
+
+ cd hdfview
+ HDFLIBS=/opt/hdf4 HDF5LIBS=/usr ant package
+}
+
+package() {
+ cd hdfview
+ mkdir "${pkgdir}/opt"
+ cp -a "build/dist/${_pkgname}-${_pkgver}-Linux.sh" "${pkgdir}/opt"
+ cd "${pkgdir}/opt"
+
+ # Make extraction non interactive
+ sed -i 's/interactive=TRUE/interactive=FALSE/' ${_pkgname}-${_pkgver}-Linux.sh
+ sed -i 's/cpack_skip_license=FALSE/cpack_skip_license=TRUE/' ${_pkgname}-${_pkgver}-Linux.sh
+
+ ./*-Linux.sh
+ rm "${_pkgname}-${_pkgver}-Linux.sh"
+ mkdir -p "${pkgdir}/usr/bin"
+
+ # Desktop files, icons, wrappers and license
+ echo "#!/usr/bin/env bash" > "${pkgdir}/usr/bin/hdfview.sh"
+ echo "/opt/HDFView/${_pkgver}/hdfview.sh "'$@' >> "${pkgdir}/usr/bin/hdfview.sh"
+ chmod 755 "${pkgdir}/usr/bin/hdfview.sh"
+ install -D -m 644 "${srcdir}/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+ install -D -m 644 "${srcdir}/${_pkgname}.ico" "${pkgdir}/usr/share/pixmaps/${_pkgname}.ico"
+ install -D -m 644 "${srcdir}/license" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/license b/license
new file mode 100644
index 000000000000..056c8f762de9
--- /dev/null
+++ b/license
@@ -0,0 +1,89 @@
+Copyright Notice and License Terms for
+HDF Java Products
+-----------------------------------------------------------------------------
+
+HDF Java Products
+Copyright 2006-2011 by The HDF Group.
+
+NCSA HDF Java Products
+Copyright 1988-2006 by the Board of Trustees of the University of Illinois.
+
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted for any purpose (including commercial purposes)
+provided that the following conditions are met:
+
+1. Redistributions of source code must retain the above copyright notice,
+ this list of conditions, and the following disclaimer.
+
+2. Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions, and the following disclaimer in the documentation
+ and/or materials provided with the distribution.
+
+3. In addition, redistributions of modified forms of the source or binary
+ code must carry prominent notices stating that the original code was
+ changed and the date of the change.
+
+4. All publications or advertising materials mentioning features or use of
+ this software are asked, but not required, to acknowledge that it was
+ developed by The HDF Group and by the National Center for Supercomputing
+ Applications at the University of Illinois at Urbana-Champaign and
+ credit the contributors.
+
+5. Neither the name of The HDF Group, the name of the University, nor the
+ name of any Contributor may be used to endorse or promote products derived
+ from this software without specific prior written permission from The HDF
+ Group, the University, or the Contributor, respectively.
+
+DISCLAIMER:
+THIS SOFTWARE IS PROVIDED BY THE HDF GROUP AND THE CONTRIBUTORS "AS IS"
+WITH NO WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED. In no event
+shall The HDF Group or the Contributors be liable for any damages suffered
+by the users arising out of the use of this software, even if advised of
+the possibility of such damage.
+
+--------------------------------------------------------------------------
+--------------------------------------------------------------------------
+
+Contributors: National Center for Supercomputing Applications (NCSA) at
+the University of Illinois, Lawrence Livermore National Laboratory (LLNL),
+Sandia National Laboratories (SNL), Los Alamos National Laboratory (LANL),
+Fortner Software, Unidata Program Center (netCDF), The Independent JPEG
+Group (JPEG), Jean-loup Gailly and Mark Adler (gzip), and Digital Equipment
+Corporation (DEC).
+
+--------------------------------------------------------------------------
+
+Portions of the HDF Java Products were developed with support from the
+University of California, Lawrence Livermore National Laboratory (UC LLNL).
+The following statement applies to those portions of the product
+and must be retained in any redistribution of source code, binaries,
+documentation, and/or accompanying materials:
+
+ This work was partially produced at the University of California,
+ Lawrence Livermore National Laboratory (UC LLNL) under contract no.
+ W-7405-ENG-48 (Contract 48) between the U.S. Department of Energy
+ (DOE) and The Regents of the University of California (University)
+ for the operation of UC LLNL.
+
+ DISCLAIMER:
+ This work was prepared as an account of work sponsored by an agency
+ of the United States Government. Neither the United States
+ Government nor the University of California nor any of their
+ employees, makes any warranty, express or implied, or assumes any
+ liability or responsibility for the accuracy, completeness, or
+ usefulness of any information, apparatus, product, or process
+ disclosed, or represents that its use would not infringe privately-
+ owned rights. Reference herein to any specific commercial products,
+ process, or service by trade name, trademark, manufacturer, or
+ otherwise, does not necessarily constitute or imply its endorsement,
+ recommendation, or favoring by the United States Government or the
+ University of California. The views and opinions of authors
+ expressed herein do not necessarily state or reflect those of the
+ United States Government or the University of California, and shall
+ not be used for advertising or product endorsement purposes.
+
+--------------------------------------------------------------------------
+
+