summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2023-01-07 22:55:06 +0000
committerEric Engestrom2023-01-07 23:24:28 +0000
commit0544d0cb92d59733581923ade6561f36892c7fea (patch)
tree52736810b6fba04c2ac279b25d8c8178ba565af5
parent9b33f39eb4c17f8073a52777b251065da3aaa4dd (diff)
downloadaur-0544d0cb92d59733581923ade6561f36892c7fea.tar.gz
update with some of dreieck's suggestions
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD26
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2e80c58423f..8a2735d594d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,10 +8,12 @@ pkgbase = hdrview-git
makedepends = git
makedepends = cmake
makedepends = ninja
+ depends = hicolor-icon-theme
+ depends = libglvnd
depends = zlib
provides = hdrview
conflicts = hdrview
- source = git+https://github.com/wkjarosz/hdrview
+ source = hdrview-git::git+https://github.com/wkjarosz/hdrview
sha256sums = SKIP
pkgname = hdrview-git
diff --git a/PKGBUILD b/PKGBUILD
index d913a8d4c14f..9d5215d44022 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,21 +10,27 @@ url='https://github.com/wkjarosz/hdrview'
arch=(x86_64)
license=(BSD)
makedepends=(git cmake ninja)
-depends=(zlib)
-source=("git+$url")
+depends=(hicolor-icon-theme libglvnd zlib)
+source=("$pkgname::git+$url")
sha256sums=('SKIP')
provides=(hdrview)
conflicts=(hdrview)
pkgver() {
- git -C $_pkgname describe --tags --abbrev=10 | sed 's/^v//; s/-/+/; s/-/./'
+ git -C $pkgname describe --tags --abbrev=10 | sed 's/^v//; s/-/+/; s/-/./'
}
build() {
- cmake -S $_pkgname -B build \
+ cmake -S $pkgname -B build \
-G Ninja \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release
+ -DCMAKE_BUILD_TYPE=Release \
+ -DFETCHCONTENT_QUIET=OFF \
+ -DIMATH_INSTALL_PKG_CONFIG=OFF \
+ -DIMATH_INSTALL_SYM_LINK=OFF \
+ -DOPENEXR_INSTALL=OFF \
+ -DOPENEXR_INSTALL_PKG_CONFIG=OFF \
+ -DOPENEXR_INSTALL_TOOLS=OFF
cmake --build build
}
@@ -38,22 +44,16 @@ package() {
-i "$pkgdir"/usr/share/applications/hdrview.desktop
# Project installs a copy of its own deps as well
- for dep in Imath OpenEXR
+ for dep in Imath
do
rm -r "$pkgdir"/usr/include/$dep/
rm -r "$pkgdir"/usr/lib/cmake/$dep/
- rm "$pkgdir"/usr/lib/pkgconfig/$dep.pc
+ rm "$pkgdir"/usr/lib/lib$dep*.a
done
- # These don't have a filename trivially derived from the dep name, but
- # the project doesn't have any static lib of its own so let's just
- # blindly remove any.
- rm "$pkgdir"/usr/lib/lib*.a
-
# Raise an error in case there's every anything else added (either
# a new dep, or the project starts shipping libs)
rmdir "$pkgdir"/usr/include/
rmdir "$pkgdir"/usr/lib/cmake/
- rmdir "$pkgdir"/usr/lib/pkgconfig/
rmdir "$pkgdir"/usr/lib/
}