summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-13 16:57:34 +0800
committerzxp198210052023-11-13 16:57:34 +0800
commit019e758caa45ce4cc5acb2693b233ae3896664f1 (patch)
tree4197b045df7a07230be0c61f3859c3cb59ae2867
parentefff68d394c2e37530331280b91a5ba1975e1e79 (diff)
downloadaur-019e758caa45ce4cc5acb2693b233ae3896664f1.tar.gz
fix errors
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD73
2 files changed, 56 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d81af78bb7a2..0f9c1561d3bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = headphones
pkgdesc = Music downloader for usenet and torrents.
pkgver = 0.6.0
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/rembo10/headphones
install = headphones.install
arch = any
license = GPL3
depends = python>=3
- depends = sh
depends = python-urllib3
depends = python-pytz
depends = python-requests-toolbelt
diff --git a/PKGBUILD b/PKGBUILD
index c94bb4c25ac1..2495d7ad0c97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,67 @@
# Contributor: Anthony Ruhier <anthony.ruhier@gmail.com>
pkgname=headphones
pkgver=0.6.0
-pkgrel=4
+pkgrel=5
pkgdesc="Music downloader for usenet and torrents."
arch=('any')
url="https://github.com/rembo10/headphones"
license=('GPL3')
-depends=('python>=3' 'sh' 'python-urllib3' 'python-pytz' 'python-requests-toolbelt' 'python-markupsafe' 'python-mako' 'python-html5lib' \
- 'python-pylast' 'python-jaraco.classes' 'python-six' 'python-musicbrainzngs' 'python-cryptography' 'python-jaraco.context' 'python-lxml' \
- 'python-certifi' 'python-colorama' 'python-jaraco.text' 'python-yaml' 'python-gobject' 'python-jaraco.functools' 'python-beautifulsoup4' \
- 'gobject-introspection-runtime' 'python-setuptools' 'python-pillow' 'python-mutagen' 'python-zipp' 'python-more-itertools' 'python-soupsieve' \
- 'python-chardet' 'python-pygments' 'python-idna' 'gstreamer' 'python-simplejson' 'python-requests' 'python-pyqt5-webkit' 'python-pyxdg')
-optdepends=('sabnzbd: usenet downloader'
- 'nzbget: usenet downloader'
- 'transmission-cli: torrent downloader (CLI and daemon)'
- 'transmission-gtk: torrent downloader (GTK+)'
- 'transmission-qt: torrent downloader (Qt)'
- 'deluge: torrent downloader'
- 'rtorrent: torrent downloader'
- 'jackett: torrent indexer proxy')
conflicts=("${pkgname}")
+depends=(
+ 'python>=3'
+ 'python-urllib3'
+ 'python-pytz'
+ 'python-requests-toolbelt'
+ 'python-markupsafe'
+ 'python-mako'
+ 'python-html5lib'
+ 'python-pylast'
+ 'python-jaraco.classes'
+ 'python-six'
+ 'python-musicbrainzngs'
+ 'python-cryptography'
+ 'python-jaraco.context'
+ 'python-lxml'
+ 'python-certifi'
+ 'python-colorama'
+ 'python-jaraco.text'
+ 'python-yaml'
+ 'python-gobject'
+ 'python-jaraco.functools'
+ 'python-beautifulsoup4'
+ 'gobject-introspection-runtime'
+ 'python-setuptools'
+ 'python-pillow'
+ 'python-mutagen'
+ 'python-zipp'
+ 'python-more-itertools'
+ 'python-soupsieve'
+ 'python-chardet'
+ 'python-pygments'
+ 'python-idna'
+ 'gstreamer'
+ 'python-simplejson'
+ 'python-requests'
+ 'python-pyqt5-webkit'
+ 'python-pyxdg'
+)
+optdepends=(
+ 'sabnzbd: usenet downloader'
+ 'nzbget: usenet downloader'
+ 'transmission-cli: torrent downloader (CLI and daemon)'
+ 'transmission-gtk: torrent downloader (GTK+)'
+ 'transmission-qt: torrent downloader (Qt)'
+ 'deluge: torrent downloader'
+ 'rtorrent: torrent downloader'
+ 'jackett: torrent indexer proxy'
+)
install="${pkgname}.install"
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz"
- "${pkgname}.service"
- "${pkgname}.sysusers"
- "${pkgname}.tmpfiles")
+source=(
+ "${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz"
+ "${pkgname}.service"
+ "${pkgname}.sysusers"
+ "${pkgname}.tmpfiles"
+)
sha256sums=('e96755547b6a6cd63f2a916d4bdfd5f5a3cc62e1b89db021de441c94c064ddc6'
'e2ba604cdd1f16274a3267f5354972bb60f462ff60ac069391e8ab778af8ec3c'
'348abc0627d63762a97655b5893c306e5b923857be5d0b876e9df5fea7ef9ed9'