summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2018-08-15 09:45:37 +0200
committerFabioLolix2018-08-15 09:45:37 +0200
commit1f5a20dbc13a57ea7ad4a647c8094a5708efddbb (patch)
tree84fd53fe8c073710ca067d6d9dae0ecf897bc5b5
parentab57359940528775cd412d62f3da87807456baca (diff)
downloadaur-1f5a20dbc13a57ea7ad4a647c8094a5708efddbb.tar.gz
v2.0.1
-rwxr-xr-x.SRCINFO13
-rwxr-xr-xPKGBUILD28
2 files changed, 15 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d67cc789988f..5f453ac012fc 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,20 @@
pkgbase = headset-bin
pkgdesc = An Electron-based music player for the busy ones
- pkgver = 1.9.0
+ pkgver = 2.0.1
pkgrel = 1
url = https://headsetapp.co/
arch = x86_64
license = MIT
- depends = alsa-lib
depends = gconf
- depends = gtk2
+ depends = gtk3
depends = nss
- depends = libxtst
depends = libxss
- depends = gcc-libs
provides = headset
conflicts = headset
- source = https://github.com/headsetapp/headset-electron/releases/download/v1.9.0/headset_1.9.0_amd64.deb
+ source = https://github.com/headsetapp/headset-electron/releases/download/v2.0.1/headset_2.0.1_amd64.deb
source = MIT::https://github.com/headsetapp/headset-electron/raw/master/LICENSE
- md5sums = 8650064804d8ba873be09285476b40ed
- md5sums = SKIP
+ md5sums = dd802476ffe47029ae5343ccc0880e96
+ md5sums = 4b21e50f5ba66d18a93fab87d11d67e0
pkgname = headset-bin
diff --git a/PKGBUILD b/PKGBUILD
index e99e8f4f418c..b522c973b17c 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,25 @@
# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
pkgname=headset-bin
-pkgver=1.9.0
+pkgver=2.0.1
pkgrel=1
pkgdesc="An Electron-based music player for the busy ones"
-arch=('x86_64')
+arch=(x86_64)
url="https://headsetapp.co/"
license=(MIT)
-depends=('alsa-lib'
- 'gconf'
- 'gtk2'
- 'nss'
- 'libxtst'
- 'libxss'
- 'gcc-libs')
-provides=('headset')
-conflicts=('headset')
+depends=(gconf gtk3 nss libxss)
+provides=(headset)
+conflicts=(headset)
source=("https://github.com/headsetapp/headset-electron/releases/download/v${pkgver}/headset_${pkgver}_amd64.deb"
"MIT::https://github.com/headsetapp/headset-electron/raw/master/LICENSE")
-md5sums=('8650064804d8ba873be09285476b40ed'
- 'SKIP')
+md5sums=('dd802476ffe47029ae5343ccc0880e96'
+ '4b21e50f5ba66d18a93fab87d11d67e0')
+PKGEXT='.pkg.tar'
package() {
bsdtar -xf ${srcdir}/data.tar.xz -C ${pkgdir}/
- rm -r ${pkgdir}/usr/share/lintian
- chmod 755 -R ${pkgdir}/
- install -d ${pkgdir}/usr/share/licenses/${pkgname}
- install MIT ${pkgdir}/usr/share/licenses/${pkgname}
+ install -Dm644 MIT ${pkgdir}/usr/share/licenses/${pkgname}/MIT
mv ${pkgdir}/usr/lib/headset/LICENSES.chromium.html ${pkgdir}/usr/share/licenses/${pkgname}
mv ${pkgdir}/usr/share/doc/headset/copyright ${pkgdir}/usr/share/licenses/${pkgname}
- rm -r ${pkgdir}/usr/share/doc
+ rm -r ${pkgdir}/usr/share/{doc,lintian}
}