summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2017-07-03 23:50:27 +0200
committerFabioLolix2017-07-03 23:50:27 +0200
commit2d671780248d71efdcc2869f155cdbea90d4cfce (patch)
tree6f121ecde425ee339363d86f223988d003cefef2
downloadaur-2d671780248d71efdcc2869f155cdbea90d4cfce.tar.gz
initial release, version 1.5.4
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore11
-rw-r--r--MIT21
-rw-r--r--PKGBUILD34
4 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..49066c50f8b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = headset-bin
+ pkgdesc = An Electron-based music player for the busy ones
+ pkgver = 1.5.4
+ pkgrel = 1
+ url = http://headsetapp.co/
+ arch = x86_64
+ license = MIT
+ depends = alsa-lib
+ depends = gconf
+ depends = gnuplot
+ depends = nodejs
+ depends = nss
+ depends = libxtst
+ depends = libxss
+ depends = gcc-libs-multilib
+ provides = headset
+ conflicts = headset
+ source = https://github.com/headsetapp/headset-electron/releases/download/v1.5.4-deb/Headset_1.5.4_amd64.deb
+ source = MIT::https://github.com/headsetapp/headset-electron/raw/master/LICENSE
+ md5sums = c0619b1508545ac25fa7722aa9b6a0c0
+ md5sums = SKIP
+
+pkgname = headset-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..834281932b64
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,11 @@
+*.gz
+*.xz
+*.zip
+*.tar*
+*.tgz
+*.bz2
+*.deb
+*.rpm
+pkg
+src
+
diff --git a/MIT b/MIT
new file mode 100644
index 000000000000..7d01b56940de
--- /dev/null
+++ b/MIT
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2017 Daniel Ravina
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7128433fc9c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Fabio Loli <loli_fabio@protonmail.com>
+
+pkgname=headset-bin
+pkgver=1.5.4
+pkgrel=1
+pkgdesc="An Electron-based music player for the busy ones"
+arch=('x86_64')
+url="http://headsetapp.co/"
+license=(MIT)
+depends=('alsa-lib'
+ 'gconf'
+ 'gnuplot'
+ 'nodejs'
+ 'nss'
+ 'libxtst'
+ 'libxss'
+ 'gcc-libs-multilib')
+provides=('headset')
+conflicts=('headset')
+#options('!emptydirs')
+source=("https://github.com/headsetapp/headset-electron/releases/download/v${pkgver}-deb/Headset_${pkgver}_amd64.deb"
+ "MIT::https://github.com/headsetapp/headset-electron/raw/master/LICENSE")
+md5sums=('c0619b1508545ac25fa7722aa9b6a0c0'
+ 'SKIP')
+
+package() {
+ bsdtar -xf ${srcdir}/data.tar.xz -C ${pkgdir}/
+ rm -r ${pkgdir}/usr/share/lintian
+ chmod 755 -R ${pkgdir}/
+ install -d ${pkgdir}/usr/share/licenses/${pkgname}
+ install MIT ${pkgdir}/usr/share/licenses/${pkgname}
+ mv ${pkgdir}/usr/lib/Headset/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}
+ mv ${pkgdir}/usr/lib/Headset/LICENSES.chromium.html ${pkgdir}/usr/share/licenses/${pkgname}
+}