summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2017-11-01 10:55:20 +0100
committerFabioLolix2017-11-01 10:55:20 +0100
commit43b396c9a62a4ed9f9870ba01c78522d7df8d8da (patch)
tree4231eb8a39ed87d86e09ed065a2cfd1e94534b68
parent2d671780248d71efdcc2869f155cdbea90d4cfce (diff)
downloadaur-43b396c9a62a4ed9f9870ba01c78522d7df8d8da.tar.gz
Updated to version 1.6.1
-rwxr-xr-x[-rw-r--r--].SRCINFO11
-rw-r--r--.gitignore11
-rw-r--r--MIT21
-rwxr-xr-x[-rw-r--r--]PKGBUILD18
4 files changed, 14 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49066c50f8b7..c6c92536121e 100644..100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,23 @@
pkgbase = headset-bin
pkgdesc = An Electron-based music player for the busy ones
- pkgver = 1.5.4
+ pkgver = 1.6.1
pkgrel = 1
url = http://headsetapp.co/
arch = x86_64
license = MIT
depends = alsa-lib
depends = gconf
- depends = gnuplot
- depends = nodejs
+ depends = gtk2
depends = nss
depends = libxtst
depends = libxss
depends = gcc-libs-multilib
provides = headset
conflicts = headset
- source = https://github.com/headsetapp/headset-electron/releases/download/v1.5.4-deb/Headset_1.5.4_amd64.deb
+ source = https://github.com/headsetapp/headset-electron/releases/download/v1.6.1/headset_1.6.1_amd64.deb
source = MIT::https://github.com/headsetapp/headset-electron/raw/master/LICENSE
- md5sums = c0619b1508545ac25fa7722aa9b6a0c0
- md5sums = SKIP
+ md5sums = 1c8b4b0ad5641c1c8da185ed33f9bec2
+ md5sums = 63f69acde84223e3a5c9545b529e9e27
pkgname = headset-bin
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 834281932b64..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,11 +0,0 @@
-*.gz
-*.xz
-*.zip
-*.tar*
-*.tgz
-*.bz2
-*.deb
-*.rpm
-pkg
-src
-
diff --git a/MIT b/MIT
deleted file mode 100644
index 7d01b56940de..000000000000
--- a/MIT
+++ /dev/null
@@ -1,21 +0,0 @@
-MIT License
-
-Copyright (c) 2017 Daniel Ravina
-
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in all
-copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 7128433fc9c8..733531620ce3 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Fabio Loli <loli_fabio@protonmail.com>
+# https://github.com/FabioLolix
pkgname=headset-bin
-pkgver=1.5.4
+pkgver=1.6.1
pkgrel=1
pkgdesc="An Electron-based music player for the busy ones"
arch=('x86_64')
@@ -9,19 +10,17 @@ url="http://headsetapp.co/"
license=(MIT)
depends=('alsa-lib'
'gconf'
- 'gnuplot'
- 'nodejs'
+ 'gtk2'
'nss'
'libxtst'
'libxss'
'gcc-libs-multilib')
provides=('headset')
conflicts=('headset')
-#options('!emptydirs')
-source=("https://github.com/headsetapp/headset-electron/releases/download/v${pkgver}-deb/Headset_${pkgver}_amd64.deb"
+source=("https://github.com/headsetapp/headset-electron/releases/download/v${pkgver}/headset_${pkgver}_amd64.deb"
"MIT::https://github.com/headsetapp/headset-electron/raw/master/LICENSE")
-md5sums=('c0619b1508545ac25fa7722aa9b6a0c0'
- 'SKIP')
+md5sums=('1c8b4b0ad5641c1c8da185ed33f9bec2'
+ '63f69acde84223e3a5c9545b529e9e27')
package() {
bsdtar -xf ${srcdir}/data.tar.xz -C ${pkgdir}/
@@ -29,6 +28,7 @@ package() {
chmod 755 -R ${pkgdir}/
install -d ${pkgdir}/usr/share/licenses/${pkgname}
install MIT ${pkgdir}/usr/share/licenses/${pkgname}
- mv ${pkgdir}/usr/lib/Headset/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}
- mv ${pkgdir}/usr/lib/Headset/LICENSES.chromium.html ${pkgdir}/usr/share/licenses/${pkgname}
+ mv ${pkgdir}/usr/lib/headset/LICENSES.chromium.html ${pkgdir}/usr/share/licenses/${pkgname}
+ mv ${pkgdir}/usr/share/doc/headset/copyright ${pkgdir}/usr/share/licenses/${pkgname}
+ rm -r ${pkgdir}/usr/share/doc
}