summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Saliés Brum2020-01-29 06:41:09 -0400
committerLucas Saliés Brum2020-01-29 06:41:09 -0400
commit9c31b53fd37a2f3f47efd4bd3445f2fea30a76d3 (patch)
tree26e2e743d1d7ee07fb4708e3faac65cef50e5d07
downloadaur-9c31b53fd37a2f3f47efd4bd3445f2fea30a76d3.tar.gz
Changed package name headsetcontrol-git to headsetcontrol
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..afb98661756c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = headsetcontrol
+ pkgdesc = Sidetone / Battery support for Logitech G533, G930, G430 and Corsair VOID (Pro) in Linux and MacOSX
+ pkgver = r106.fed7c7f
+ pkgrel = 1
+ url = https://github.com/Sapd/HeadsetControl
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ depends = hidapi
+ provides = headsetcontrol
+ conflicts = headsetcontrol
+ source = headsetcontrol::git+https://github.com/Sapd/HeadsetControl.git
+ md5sums = SKIP
+
+pkgname = headsetcontrol
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..334107cf3a82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Lucas Saliés Brum <lucas@archlinux.com.br>
+
+pkgname=headsetcontrol
+pkgver=r106.fed7c7f
+pkgrel=1
+pkgdesc="Sidetone / Battery support for Logitech G533, G930, G430 and Corsair VOID (Pro) in Linux and MacOSX"
+arch=('x86_64')
+url="https://github.com/Sapd/HeadsetControl"
+license=('GPL')
+depends=('hidapi')
+makedepends=('git' 'cmake')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname%-git}::git+https://github.com/Sapd/HeadsetControl.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}/src"
+ cmake ..
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}/src"
+ make DESTDIR="$pkgdir/" install
+ #ln -s /usr/local/bin/HeadsetControl ${pkgdir}/usr/local/bin/headsetcontrol
+ install -m644 ../udev/*.rules ${pkgdir}/etc/udev/rules.d/
+}