summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Saliés Brum2020-11-10 11:53:49 -0400
committerLucas Saliés Brum2020-11-10 11:53:49 -0400
commit06ffc174c6f3f2d1d9ce3aa4d81e1bac4f44a60b (patch)
tree98c75e8f99ec65373f4a9d398f25beec539c7755
parent0ad0bda679d4d039e4938c750e92759c588a19cd (diff)
downloadaur-06ffc174c6f3f2d1d9ce3aa4d81e1bac4f44a60b.tar.gz
First commit
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD28
2 files changed, 17 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e511368e9d64..26b376895a68 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,9 @@
pkgbase = headsetcontrol-git
- pkgdesc = Sidetone support for Logitech G930, G430 and Corsair VOID (Pro) in Linux and MacOSX
- pkgver = r86.3979f9b
+ pkgdesc = Sidetone and Battery status for Logitech G930, G533, G633, G933 SteelSeries Arctis 7/PRO 2019 and Corsair VOID (Pro) in Linux and MacOSX
+ pkgver = r146.23bf9d9
pkgrel = 1
- url = https://github.com/Sapd/HeadsetControl
arch = x86_64
- license = GPL
- makedepends = git
+ license = GPL3
makedepends = cmake
depends = hidapi
provides = headsetcontrol
diff --git a/PKGBUILD b/PKGBUILD
index 67d1a30aad40..e2ba7e39c818 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,32 @@
-# Maintainer: Josué M. Sehnem <josue@sehnem.com>
+# Maintainer: Lucas Saliés Brum <lucas@archlinux.com.br>
+
pkgname=headsetcontrol-git
-pkgver=r80.0498a13
+pkgver=r146.23bf9d9
pkgrel=1
-pkgdesc="Sidetone support for Logitech G930, G533, G633, G933 SteelSeries Arctis 7/PRO 2019 and Corsair VOID (Pro) in Linux"
-arch=('i686' 'x86_64')
+pkgdesc="Sidetone and Battery status for Logitech G930, G533, G633, G933 SteelSeries Arctis 7/PRO 2019 and Corsair VOID (Pro) in Linux and MacOSX"
+arch=('x86_64')
license=('GPL3')
depends=('hidapi')
makedepends=('cmake')
-provides=('headsetcontrol')
-install=headsetcontrol.install
-source=("${pkgname}"'::git+https://github.com/Sapd/HeadsetControl')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname%-git}::git+https://github.com/Sapd/HeadsetControl.git")
md5sums=('SKIP')
pkgver() {
- cd "${srcdir}/${pkgname}"
- printf "r%s.%s" "$(git rev-list HEAD --count --first-parent)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "${srcdir}/${pkgname}"
- mkdir -p build
- cd build
+ cd "${srcdir}/${pkgname%-git}"
+ mkdir -p build && cd build
cmake ..
make
}
package() {
- cd "${srcdir}/${pkgname}"
- cd build
+ cd "$srcdir/${pkgname%-git}/build"
make DESTDIR="${pkgdir}" install
+ install -m644 ../udev/*.rules ${pkgdir}/etc/udev/rules.d/
}