summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2021-01-06 15:54:52 +1300
committercaltlgin2021-01-06 15:54:52 +1300
commit6446b614569edd61c87221afd93429757531b251 (patch)
tree6fc9c15dd812375c7f5eba6077a919c62b8a8e0e
parent06ffc174c6f3f2d1d9ce3aa4d81e1bac4f44a60b (diff)
downloadaur-6446b614569edd61c87221afd93429757531b251.tar.gz
Refactor PKGBUILD
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD42
-rw-r--r--headsetcontrol.install13
4 files changed, 34 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26b376895a68..a95e5c7f1a36 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = headsetcontrol-git
- pkgdesc = Sidetone and Battery status for Logitech G930, G533, G633, G933 SteelSeries Arctis 7/PRO 2019 and Corsair VOID (Pro) in Linux and MacOSX
- pkgver = r146.23bf9d9
+ pkgdesc = Sidetone and Battery status for Logitech G930, G533, G633, G933 SteelSeries Arctis 7/PRO 2019 and Corsair VOID (Pro)
+ pkgver = 2.3.r52.gc7122e9
pkgrel = 1
+ url = https://github.com/Sapd/HeadsetControl
arch = x86_64
license = GPL3
makedepends = cmake
+ makedepends = git
depends = hidapi
provides = headsetcontrol
conflicts = headsetcontrol
source = headsetcontrol::git+https://github.com/Sapd/HeadsetControl.git
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = headsetcontrol-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..623d0e70ff3e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+
diff --git a/PKGBUILD b/PKGBUILD
index e2ba7e39c818..88751b0e6936 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,38 @@
-# Maintainer: Lucas Saliés Brum <lucas@archlinux.com.br>
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Contributor: Lucas Saliés Brum <lucas@archlinux.com.br>
-pkgname=headsetcontrol-git
-pkgver=r146.23bf9d9
+_pkgname='headsetcontrol'
+pkgname="${_pkgname}-git"
+pkgver=2.3.r52.gc7122e9
pkgrel=1
-pkgdesc="Sidetone and Battery status for Logitech G930, G533, G633, G933 SteelSeries Arctis 7/PRO 2019 and Corsair VOID (Pro) in Linux and MacOSX"
+pkgdesc='Sidetone and Battery status for Logitech G930, G533, G633, G933 SteelSeries Arctis 7/PRO 2019 and Corsair VOID (Pro)'
arch=('x86_64')
+url='https://github.com/Sapd/HeadsetControl'
license=('GPL3')
depends=('hidapi')
-makedepends=('cmake')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-source=("${pkgname%-git}::git+https://github.com/Sapd/HeadsetControl.git")
-md5sums=('SKIP')
+makedepends=('cmake' 'git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+${url}.git")
+sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git -C "${_pkgname}" describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/${pkgname%-git}"
- mkdir -p build && cd build
- cmake ..
- make
+ export CFLAGS+=" ${CPPFLAGS}"
+ export CXXFLAGS+=" ${CPPFLAGS}"
+ cmake -B 'build' -S "${_pkgname}" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
+ make -C 'build'
}
package() {
- cd "$srcdir/${pkgname%-git}/build"
- make DESTDIR="${pkgdir}" install
- install -m644 ../udev/*.rules ${pkgdir}/etc/udev/rules.d/
+ make DESTDIR="${pkgdir}" PREFIX='/usr' -C 'build' install
+ install -Dvm644 "${_pkgname}/README.md" -t "${pkgdir}/usr/share/doc/${_pkgname}"
}
+
+# vim: ts=2 sw=2 et:
diff --git a/headsetcontrol.install b/headsetcontrol.install
deleted file mode 100644
index 2504e03ae2c8..000000000000
--- a/headsetcontrol.install
+++ /dev/null
@@ -1,13 +0,0 @@
-pkgname=headsetcontrol-git
-
-post_install() {
- update-mime-database usr/share/mime > /dev/null
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install $1
-}