summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authors3lph2023-07-03 22:20:52 +0200
committers3lph2023-07-03 22:20:52 +0200
commitc35e6dd439286b0c153ea2e8da9ac976704d8cea (patch)
treef915f83b06482ee10b38047f3b53104df32aa2f6
parent6446b614569edd61c87221afd93429757531b251 (diff)
downloadaur-c35e6dd439286b0c153ea2e8da9ac976704d8cea.tar.gz
fix: include udev rules in package
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 88751b0e6936..b84cf09e1b26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
# Contributor: Lucas SaliƩs Brum <lucas@archlinux.com.br>
+# Contributor: s3lph <aur-hsdquy@s3lph.me>
_pkgname='headsetcontrol'
pkgname="${_pkgname}-git"
-pkgver=2.3.r52.gc7122e9
-pkgrel=1
+pkgver=2.7.0.r1.gbd8aed3
+pkgrel=2
pkgdesc='Sidetone and Battery status for Logitech G930, G533, G633, G933 SteelSeries Arctis 7/PRO 2019 and Corsair VOID (Pro)'
arch=('x86_64')
url='https://github.com/Sapd/HeadsetControl'
license=('GPL3')
depends=('hidapi')
makedepends=('cmake' 'git')
-provides=("${_pkgname}")
+provides=("${_pkgname}=${pkgver}")
conflicts=("${_pkgname}")
source=("${_pkgname}::git+${url}.git")
sha256sums=('SKIP')
pkgver() {
- git -C "${_pkgname}" describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${_pkgname}"
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
@@ -33,6 +35,8 @@ build() {
package() {
make DESTDIR="${pkgdir}" PREFIX='/usr' -C 'build' install
install -Dvm644 "${_pkgname}/README.md" -t "${pkgdir}/usr/share/doc/${_pkgname}"
+ install -dvm755 "${pkgdir}/usr/lib/udev/rules.d/"
+ "${pkgdir}/usr/bin/headsetcontrol" -u > "${pkgdir}/usr/lib/udev/rules.d/70-headsets.rules"
}
# vim: ts=2 sw=2 et: