summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2024-01-21 10:48:51 -0800
committerxiota2024-01-21 10:48:51 -0800
commit93391fca15961be61714cb8f0625695a5b1a4052 (patch)
tree0daf6c426e42f88f1d6bd93fad4d76e0ad9c2005
parentd35d89760964b00ad457eca07855143a1dcbabdf (diff)
downloadaur-health.tar.gz
0.95.0
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD62
-rw-r--r--blueprint_version_0.94.0.patch26
-rw-r--r--max_size_tightending_thresh_0.94.0.patch15
-rw-r--r--max_value_0.94.0.patch12
6 files changed, 38 insertions, 103 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5429f8484775..1d9651d8537c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,18 @@
pkgbase = health
pkgdesc = A health tracking app for the GNOME desktop
- pkgver = 0.94.0
- pkgrel = 4
+ pkgver = 0.95.0
+ pkgrel = 1
url = https://gitlab.gnome.org/World/Health
arch = x86_64
- license = GPL3
- checkdepends = appstream-glib
+ license = GPL-3.0-or-later
+ makedepends = blueprint-compiler
makedepends = meson
makedepends = rust
- makedepends = blueprint-compiler
- depends = libadwaita
depends = gtk4
- source = health-0.94.0.tar.gz::https://gitlab.gnome.org/World/Health/-/archive/0.94.0/Health-0.94.0.tar.gz
- source = blueprint_version_0.94.0.patch
- source = max_value_0.94.0.patch
- source = max_size_tightending_thresh_0.94.0.patch
- sha512sums = 2cf4314de185c2ad8c42cd51385e7b9ab895932a429e6afb2ece29f24da951b49cb5e8ef184c377cc48a1e6bf6f997c0cd539623a4c5603e91dff70219c4bcab
- sha512sums = 91d20d5e74de2b3a45ab2a2393d24bee8a434c006904e0bf0844f8acac1f0006d2d3357cd5c48b7401a9dd45ffda9e5c89087357b2a8bbaf15a11d62373d5280
- sha512sums = 24b43f8127d0d0250f4198dd77f8e4a7ceadb0e21e67adfcf147a5992b429ad73d4fa7c46cc30f43a2aef0a505f259ddf380b0043894a742c10cc7053c9a9301
- sha512sums = 79b5e8b757a131820ee8c42fb2e8d30a867194692b72ebafd34c82131ec620aca790744911d7a01740a657b5c3ce60efa0a4aa34be07470d3e77f23b84ffac7c
+ depends = libadwaita
+ provides = gnome-health=0.95.0
+ conflicts = gnome-health
+ source = health-0.95.0.tar.gz::https://gitlab.gnome.org/World/Health/-/archive/0.95.0/Health-0.95.0.tar.gz
+ sha256sums = bf712d2142824d209a7992107620b3d9523c6315f5c6689faa027b8cbcb26fd5
pkgname = health
diff --git a/.gitignore b/.gitignore
index ef80715c5843..018a3de08144 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,6 +2,3 @@
!PKGBUILD
!.SRCINFO
!.gitignore
-!blueprint_version_0.94.0.patch
-!max_value_0.94.0.patch
-!max_size_tightending_thresh_0.94.0.patch
diff --git a/PKGBUILD b/PKGBUILD
index 2c6e8f0a4cf0..1ad3d47131ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,38 @@
-# Maintainer: Dušan Simić <dusan.simic1810@gmail.com>
+# Maintainer:
+# Contributor: Dušan Simić <dusan.simic1810@gmail.com>
-pkgname=health
-_reponame=Health
-pkgver=0.94.0
-pkgrel=4
+_pkgname="health"
+pkgname="$_pkgname"
+pkgver=0.95.0
+pkgrel=1
pkgdesc="A health tracking app for the GNOME desktop"
-arch=(x86_64)
-url=https://gitlab.gnome.org/World/Health
-license=(GPL3)
-depends=(libadwaita gtk4)
-checkdepends=(appstream-glib)
-makedepends=(meson rust blueprint-compiler)
-source=("$pkgname-$pkgver.tar.gz::$url/-/archive/$pkgver/$_reponame-$pkgver.tar.gz"
- "blueprint_version_0.94.0.patch"
- "max_value_0.94.0.patch"
- "max_size_tightending_thresh_0.94.0.patch")
-sha512sums=('2cf4314de185c2ad8c42cd51385e7b9ab895932a429e6afb2ece29f24da951b49cb5e8ef184c377cc48a1e6bf6f997c0cd539623a4c5603e91dff70219c4bcab'
- '91d20d5e74de2b3a45ab2a2393d24bee8a434c006904e0bf0844f8acac1f0006d2d3357cd5c48b7401a9dd45ffda9e5c89087357b2a8bbaf15a11d62373d5280'
- '24b43f8127d0d0250f4198dd77f8e4a7ceadb0e21e67adfcf147a5992b429ad73d4fa7c46cc30f43a2aef0a505f259ddf380b0043894a742c10cc7053c9a9301'
- '79b5e8b757a131820ee8c42fb2e8d30a867194692b72ebafd34c82131ec620aca790744911d7a01740a657b5c3ce60efa0a4aa34be07470d3e77f23b84ffac7c')
+url="https://gitlab.gnome.org/World/Health"
+license=('GPL-3.0-or-later')
+arch=('x86_64')
-prepare() {
- cd "$_reponame-$pkgver"
- patch -p1 -i "$srcdir/blueprint_version_0.94.0.patch"
- patch -p1 -i "$srcdir/max_value_0.94.0.patch"
- patch -p1 -i "$srcdir/max_size_tightending_thresh_0.94.0.patch"
-}
+depends=(
+ 'gtk4'
+ 'libadwaita'
+)
+makedepends=(
+ 'blueprint-compiler'
+ 'meson'
+ 'rust'
+)
-build() {
- arch-meson "$_reponame-$pkgver" build
- meson compile -C build
-}
+provides=("gnome-health=$pkgver")
+conflicts=("gnome-health")
-check() {
- # meson test -C build --print-errorlogs
- :
+_pkgsrc="Health-$pkgver"
+_pkgext="tar.gz"
+source=("$_pkgname-$pkgver.$_pkgext"::"$url/-/archive/$pkgver/$_pkgsrc.$_pkgext")
+sha256sums=('bf712d2142824d209a7992107620b3d9523c6315f5c6689faa027b8cbcb26fd5')
+
+build() {
+ arch-meson "$_pkgsrc" build
+ meson compile -C build
}
package() {
- meson install -C build --destdir "$pkgdir"
+ meson install -C build --destdir "$pkgdir"
}
diff --git a/blueprint_version_0.94.0.patch b/blueprint_version_0.94.0.patch
deleted file mode 100644
index 358d087ab9ee..000000000000
--- a/blueprint_version_0.94.0.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/dev.Cogitri.Health.Devel.json b/dev.Cogitri.Health.Devel.json
-index d95324fa13eacb7b5f95faa9c5d579d23324ba07..f80323673c635efc5e762a1d0c3f5c6464252946 100644
---- a/dev.Cogitri.Health.Devel.json
-+++ b/dev.Cogitri.Health.Devel.json
-@@ -51,7 +51,7 @@
- {
- "type": "git",
- "url": "https://gitlab.gnome.org/jwestman/blueprint-compiler",
-- "commit": "93f2a27e35905420e70bfdb5c2f04d6af43b357d"
-+ "commit": "87cedc2c7e48b01dc1b07aef937e2fe02111b18c"
- }
- ]
- },
-diff --git a/subprojects/blueprint-compiler.wrap b/subprojects/blueprint-compiler.wrap
-index 142ed4b9b9ecb2f5334ddb424349b7bcb9df9d3a..ba837c025a5b241fb1efe90714d3470cf2613a35 100644
---- a/subprojects/blueprint-compiler.wrap
-+++ b/subprojects/blueprint-compiler.wrap
-@@ -1,7 +1,7 @@
- [wrap-git]
- directory = blueprint-compiler
- url = https://gitlab.gnome.org/jwestman/blueprint-compiler.git
--revision = 93f2a27e35905420e70bfdb5c2f04d6af43b357d
-+revision = 87cedc2c7e48b01dc1b07aef937e2fe02111b18c
- depth = 1
-
- [provide]
diff --git a/max_size_tightending_thresh_0.94.0.patch b/max_size_tightending_thresh_0.94.0.patch
deleted file mode 100644
index 28a285638d48..000000000000
--- a/max_size_tightending_thresh_0.94.0.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/data/ui/setup_window.blp b/data/ui/setup_window.blp
-index fd948d2..b73cfaf 100644
---- a/data/ui/setup_window.blp
-+++ b/data/ui/setup_window.blp
-@@ -293,8 +293,8 @@ template HealthSetupWindow : Adw.ApplicationWindow {
- }
-
- Adw.Clamp {
-- maximum-size: "400";
-- tightening-threshold: "200";
-+ maximum-size: 400;
-+ tightening-threshold: 200;
- valign: center;
- vexpand: true;
- hexpand: true;
diff --git a/max_value_0.94.0.patch b/max_value_0.94.0.patch
deleted file mode 100644
index 54a3b34bad5d..000000000000
--- a/max_value_0.94.0.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/data/ui/password_entry.blp b/data/ui/password_entry.blp
-index 81be5971f784d2b3710f97ee728f1471729cfdca..6fefbb43bb8a6b89440b0998b2b1f3e4e67eac6e 100644
---- a/data/ui/password_entry.blp
-+++ b/data/ui/password_entry.blp
-@@ -67,7 +67,6 @@ template HealthPasswordEntry : Adw.Bin {
- }
-
- LevelBar password_strength_bar {
-- max-value: 5;
- mode: discrete;
- margin-start: 6;
- margin-end: 6;