summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDušan Simić2023-05-07 04:15:19 +0200
committerDušan Simić2023-05-07 04:15:19 +0200
commitd35d89760964b00ad457eca07855143a1dcbabdf (patch)
treed57b7bc50d67fa1bcecb26b2618932d7f267ec68
parent7cf7956d3cfe406b824940d5a4e8f9bae87f6710 (diff)
downloadaur-d35d89760964b00ad457eca07855143a1dcbabdf.tar.gz
Change url, patch source
* Project url is changed * Sources are patched so they can build with latest compilers
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD18
-rw-r--r--blueprint_version_0.94.0.patch (renamed from blueprint_version.patch)12
-rw-r--r--max_size_tightending_thresh_0.94.0.patch15
-rw-r--r--max_value_0.94.0.patch12
6 files changed, 51 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17840a3cc237..5429f8484775 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,23 @@
pkgbase = health
pkgdesc = A health tracking app for the GNOME desktop
pkgver = 0.94.0
- pkgrel = 3
- url = https://gitlab.gnome.org/Cogitri/Health
+ pkgrel = 4
+ url = https://gitlab.gnome.org/World/Health
arch = x86_64
license = GPL3
checkdepends = appstream-glib
makedepends = meson
makedepends = rust
makedepends = blueprint-compiler
- makedepends = python-gobject
depends = libadwaita
depends = gtk4
- source = health-0.94.0.tar.gz::https://gitlab.gnome.org/Cogitri/Health/-/archive/0.94.0/Health-0.94.0.tar.gz
- source = blueprint_version.patch
+ source = health-0.94.0.tar.gz::https://gitlab.gnome.org/World/Health/-/archive/0.94.0/Health-0.94.0.tar.gz
+ source = blueprint_version_0.94.0.patch
+ source = max_value_0.94.0.patch
+ source = max_size_tightending_thresh_0.94.0.patch
sha512sums = 2cf4314de185c2ad8c42cd51385e7b9ab895932a429e6afb2ece29f24da951b49cb5e8ef184c377cc48a1e6bf6f997c0cd539623a4c5603e91dff70219c4bcab
- sha512sums = c37665c6c54cf0bc427aa93cb9186be3ec657a63765e149283c92077937312034cffb5231262423421b4c71eedc066e2a83f33f79b62919c5b937c7a8f32280c
+ sha512sums = 91d20d5e74de2b3a45ab2a2393d24bee8a434c006904e0bf0844f8acac1f0006d2d3357cd5c48b7401a9dd45ffda9e5c89087357b2a8bbaf15a11d62373d5280
+ sha512sums = 24b43f8127d0d0250f4198dd77f8e4a7ceadb0e21e67adfcf147a5992b429ad73d4fa7c46cc30f43a2aef0a505f259ddf380b0043894a742c10cc7053c9a9301
+ sha512sums = 79b5e8b757a131820ee8c42fb2e8d30a867194692b72ebafd34c82131ec620aca790744911d7a01740a657b5c3ce60efa0a4aa34be07470d3e77f23b84ffac7c
pkgname = health
diff --git a/.gitignore b/.gitignore
index 25153fa62612..ef80715c5843 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,6 @@
!PKGBUILD
!.SRCINFO
!.gitignore
-!blueprint_version.patch
+!blueprint_version_0.94.0.patch
+!max_value_0.94.0.patch
+!max_size_tightending_thresh_0.94.0.patch
diff --git a/PKGBUILD b/PKGBUILD
index fc1b437b7200..2c6e8f0a4cf0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,28 @@
pkgname=health
_reponame=Health
pkgver=0.94.0
-pkgrel=3
+pkgrel=4
pkgdesc="A health tracking app for the GNOME desktop"
arch=(x86_64)
-url=https://gitlab.gnome.org/Cogitri/Health
+url=https://gitlab.gnome.org/World/Health
license=(GPL3)
depends=(libadwaita gtk4)
checkdepends=(appstream-glib)
-makedepends=(meson rust blueprint-compiler python-gobject)
+makedepends=(meson rust blueprint-compiler)
source=("$pkgname-$pkgver.tar.gz::$url/-/archive/$pkgver/$_reponame-$pkgver.tar.gz"
- "blueprint_version.patch")
+ "blueprint_version_0.94.0.patch"
+ "max_value_0.94.0.patch"
+ "max_size_tightending_thresh_0.94.0.patch")
sha512sums=('2cf4314de185c2ad8c42cd51385e7b9ab895932a429e6afb2ece29f24da951b49cb5e8ef184c377cc48a1e6bf6f997c0cd539623a4c5603e91dff70219c4bcab'
- 'c37665c6c54cf0bc427aa93cb9186be3ec657a63765e149283c92077937312034cffb5231262423421b4c71eedc066e2a83f33f79b62919c5b937c7a8f32280c')
+ '91d20d5e74de2b3a45ab2a2393d24bee8a434c006904e0bf0844f8acac1f0006d2d3357cd5c48b7401a9dd45ffda9e5c89087357b2a8bbaf15a11d62373d5280'
+ '24b43f8127d0d0250f4198dd77f8e4a7ceadb0e21e67adfcf147a5992b429ad73d4fa7c46cc30f43a2aef0a505f259ddf380b0043894a742c10cc7053c9a9301'
+ '79b5e8b757a131820ee8c42fb2e8d30a867194692b72ebafd34c82131ec620aca790744911d7a01740a657b5c3ce60efa0a4aa34be07470d3e77f23b84ffac7c')
prepare() {
cd "$_reponame-$pkgver"
- patch -p1 -i "$srcdir/blueprint_version.patch"
+ patch -p1 -i "$srcdir/blueprint_version_0.94.0.patch"
+ patch -p1 -i "$srcdir/max_value_0.94.0.patch"
+ patch -p1 -i "$srcdir/max_size_tightending_thresh_0.94.0.patch"
}
build() {
diff --git a/blueprint_version.patch b/blueprint_version_0.94.0.patch
index cd819765eb1f..358d087ab9ee 100644
--- a/blueprint_version.patch
+++ b/blueprint_version_0.94.0.patch
@@ -1,15 +1,3 @@
-diff --git a/data/ui/password_entry.blp b/data/ui/password_entry.blp
-index 81be5971f784d2b3710f97ee728f1471729cfdca..6fefbb43bb8a6b89440b0998b2b1f3e4e67eac6e 100644
---- a/data/ui/password_entry.blp
-+++ b/data/ui/password_entry.blp
-@@ -67,7 +67,6 @@ template HealthPasswordEntry : Adw.Bin {
- }
-
- LevelBar password_strength_bar {
-- max-value: 5;
- mode: discrete;
- margin-start: 6;
- margin-end: 6;
diff --git a/dev.Cogitri.Health.Devel.json b/dev.Cogitri.Health.Devel.json
index d95324fa13eacb7b5f95faa9c5d579d23324ba07..f80323673c635efc5e762a1d0c3f5c6464252946 100644
--- a/dev.Cogitri.Health.Devel.json
diff --git a/max_size_tightending_thresh_0.94.0.patch b/max_size_tightending_thresh_0.94.0.patch
new file mode 100644
index 000000000000..28a285638d48
--- /dev/null
+++ b/max_size_tightending_thresh_0.94.0.patch
@@ -0,0 +1,15 @@
+diff --git a/data/ui/setup_window.blp b/data/ui/setup_window.blp
+index fd948d2..b73cfaf 100644
+--- a/data/ui/setup_window.blp
++++ b/data/ui/setup_window.blp
+@@ -293,8 +293,8 @@ template HealthSetupWindow : Adw.ApplicationWindow {
+ }
+
+ Adw.Clamp {
+- maximum-size: "400";
+- tightening-threshold: "200";
++ maximum-size: 400;
++ tightening-threshold: 200;
+ valign: center;
+ vexpand: true;
+ hexpand: true;
diff --git a/max_value_0.94.0.patch b/max_value_0.94.0.patch
new file mode 100644
index 000000000000..54a3b34bad5d
--- /dev/null
+++ b/max_value_0.94.0.patch
@@ -0,0 +1,12 @@
+diff --git a/data/ui/password_entry.blp b/data/ui/password_entry.blp
+index 81be5971f784d2b3710f97ee728f1471729cfdca..6fefbb43bb8a6b89440b0998b2b1f3e4e67eac6e 100644
+--- a/data/ui/password_entry.blp
++++ b/data/ui/password_entry.blp
+@@ -67,7 +67,6 @@ template HealthPasswordEntry : Adw.Bin {
+ }
+
+ LevelBar password_strength_bar {
+- max-value: 5;
+ mode: discrete;
+ margin-start: 6;
+ margin-end: 6;